summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/lightmediascanner
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-multimedia/lightmediascanner
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-multimedia/lightmediascanner')
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend16
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb14
2 files changed, 15 insertions, 15 deletions
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
index b47b2796..5208933d 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
@@ -1,7 +1,7 @@
# Disable everything but the roygalty-free formats
PACKAGECONFIG = "ogg flac wave m3u pls jpeg png"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://lightmediascanner.service \
file://plugin-ogg-fix-chucksize-issue.patch \
@@ -9,15 +9,15 @@ SRC_URI += "file://lightmediascanner.service \
file://dbus-lightmediascanner.conf \
"
-CFLAGS_append = " -D_FILE_OFFSET_BITS=64"
+CFLAGS:append = " -D_FILE_OFFSET_BITS=64"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "lightmediascanner.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "lightmediascanner.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
-do_install_append() {
+do_install:append() {
# Install LMS systemd service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
@@ -28,7 +28,7 @@ do_install_append() {
install -m 0644 ${WORKDIR}/dbus-lightmediascanner.conf ${D}/etc/dbus-1/system.d/org.lightmediascanner.conf
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_system_unitdir}/lightmediascanner.service', '', d)} \
"
@@ -36,7 +36,7 @@ EXTRA_OECONF = "--enable-static --with-dbus-services=${datadir}/dbus-1/system-se
PACKAGECONFIG[mp4] = "--enable-mp4,--disable-mp4,libmp4v2"
# add support MP3 because of the format of music files for AGL CES/ALS2017 Demo
-PACKAGECONFIG_append = " id3 mp4"
+PACKAGECONFIG:append = " id3 mp4"
# add required character sets for id3 tag scanning
-RDEPENDS_${PN}_append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"
+RDEPENDS:${PN}:append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb b/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
index f2158760..09a8b19c 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
@@ -34,7 +34,7 @@ PACKAGECONFIG[rm] = "--enable-rm,--disable-rm"
PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg"
PACKAGECONFIG[png] = "--enable-png,--disable-png"
-do_install_append() {
+do_install:append() {
# Install "test" binary for corresponding package
install -d ${D}/${bindir}
install -m 755 ${B}/src/bin/.libs/test ${D}/${bindir}/test-lms
@@ -42,22 +42,22 @@ do_install_append() {
rm -f ${D}/${libdir}/${PN}/plugins/*.la
}
-FILES_${PN} += "${datadir}/dbus-1"
-FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
+FILES:${PN} += "${datadir}/dbus-1"
+FILES:${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
-PACKAGES_prepend = "${PN}-test "
+PACKAGES:prepend = "${PN}-test "
FILES_${PN}-test_prepend = "${bindir}/test-lms "
PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
+ALLOW_EMPTY:${PN}-meta = "1"
PACKAGES_DYNAMIC = "${PN}-plugin-*"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
lms_libdir = d.expand('${libdir}/${PN}')
pkgs = []
pkgs += do_split_packages(d, oe.path.join(lms_libdir, "plugins"), '^(.*)\.so$', d.expand('${PN}-plugin-%s'), 'LightMediaScanner plugin for %s', prepend=True, extra_depends=d.expand('${PN}'))
metapkg = d.getVar('PN') + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
+ d.setVar('RDEPENDS:' + metapkg, ' '.join(pkgs))
}