summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/module-router/module-router_git.bb
diff options
context:
space:
mode:
authorToshiaki Isogai <tisogai@jp.adit-jv.com>2016-12-23 07:04:48 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-27 17:40:01 +0000
commitd7c4e0d888a0ff61ac9b7b3fb91b6bd28aed7dd1 (patch)
tree4dfc05cb88dc43c678ab2caa5f3f675a99095026 /recipes-multimedia/module-router/module-router_git.bb
parentcda9d972b6bab2d942468f13edf25118b183b366 (diff)
Integrate GENIVI Audio Manager Plugins for CES2017 demo.
Change-Id: I56081180f8dc3bc10159492d4bc7e5fdd621ab27 Signed-off-by: Toshiaki Isogai <tisogai@jp.adit-jv.com>
Diffstat (limited to 'recipes-multimedia/module-router/module-router_git.bb')
-rwxr-xr-xrecipes-multimedia/module-router/module-router_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-multimedia/module-router/module-router_git.bb b/recipes-multimedia/module-router/module-router_git.bb
new file mode 100755
index 00000000..e8438240
--- /dev/null
+++ b/recipes-multimedia/module-router/module-router_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Pulseaudio router module"
+HOMEPAGE = "https://github.com/tisogai/module-router"
+LICENSE = "LGPLv2"
+SECTION = "multimedia"
+DEPENDS = "pulseaudio"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
+
+SRC_URI = " \
+ git://github.com/tisogai/module-router.git;protocol=https;branch=master \
+ "
+
+SRCREV = "10b9b8bbd890dcd9acb55d4bb12f80659e1338b6"
+
+S = "${WORKDIR}/git"
+inherit cmake
+OECMAKE_CXX_FLAGS += "-std=c++11"
+
+# NOTE: The specific product should have a separate customtypes.xsd
+# and should be appended to FILES_${PN} in product specific
+# audiomanager-generic-controller_git.bbappend
+FILES_${PN} = " \
+ ${libdir}/pulse-*/modules/module-router.so \
+"
+
+
+FILES_${PN}-dbg += " \
+ ${libdir}/pulse-*/modules/.debug/module-router.so \
+"
+
+