summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-01 21:55:30 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-02 13:17:21 +0000
commita2d63e7f6b3f98487ce89591a806ce6315bc14dc (patch)
treeea5a6392509e65ff6117bde83abae0b664721b01 /recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
parentb6c91bb70f8ed7200dd43bb115bee51bc82d613a (diff)
TTS Engine: Added support for Japanese TTS engine
This patch will add a temporary TTS engine for CES 2017 demo This recipe integrates the Japanese TTS engine and the data it needs Flite are necessary for voice-guide function of navigation app Change-Id: I92c3ba8584ab10c1a731a335316b7762f5f57a77 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Diffstat (limited to 'recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb')
-rw-r--r--recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb b/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
new file mode 100644
index 00000000..27ef7b57
--- /dev/null
+++ b/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
@@ -0,0 +1,22 @@
+SUMMARY = "MMDAgent Voice Data."
+HOMEPAGE = "https://sourceforge.net/projects/mmdagent/"
+SECTION = "libs"
+LICENSE = "CC-BY-3.0"
+
+inherit allarch
+
+LIC_FILES_CHKSUM = "file://Voice/mei/COPYRIGHT.txt;md5=4efd58b40631c9d879e28ce678480081"
+
+SRC_URI = "http://downloads.sourceforge.net/project/mmdagent/MMDAgent_Example/MMDAgent_Example-${PV}/MMDAgent_Example-${PV}.zip "
+
+SRC_URI[md5sum] = "b95a1ae9897a17cfac55b913565d981a"
+SRC_URI[sha256sum] = "2640ede5831a83e19f9cd8dabca9ad07ef05c50af06c6bc8cb3adfb5e5d4f639"
+
+S = "${WORKDIR}/MMDAgent_Example-${PV}"
+
+do_install() {
+ install -m 0755 -d ${D}/${datadir}/Voice/mei
+ install -m 0644 -p ${S}/Voice/mei/*.htsvoice ${D}/${datadir}/Voice/mei/
+}
+
+FILES_${PN} += " ${datadir}/Voice/mei/*.htsvoice "