summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/pulseaudio-config-module-router
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-11-03 10:13:50 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-03 19:20:24 +0000
commit3294d066144cc61df3717af95bca8032f8386375 (patch)
tree13b0b3ac1dbe6342e9c7633f216d43a26948c3e0 /recipes-multimedia/pulseaudio-config-module-router
parente96107e981c04b71e81986dc2528e06ae7515488 (diff)
Rework PulseAudio / audiomanager config setup to allow over-rides
Changes include: - Move from having PulseAudio configuration changes in the recipe bbappend as patches to using the .include directive in default.pa to pick up configuration fragments provided by other recipes. - Use virtual/pulseaudio-config to pick up the previously hard-coded configuration for enabling module-router.so, which is now provided by a new recipe that sets RPROVIDES appropriately. This allows over-riding the desired configuration if needed. - Switch the audiomanager-plugins-config dependency to using virtual/audiomanager-plugins-config so that it can be over-ridden with PREFERRED_PROVIDER if needed. Bug-AGL: SPEC-1025, SPEC-1026, SPEC-1027 Change-Id: Ifdf16871cddc2bec7761b8c63239623b63c9e984 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-multimedia/pulseaudio-config-module-router')
-rw-r--r--recipes-multimedia/pulseaudio-config-module-router/files/module-router.pa7
-rw-r--r--recipes-multimedia/pulseaudio-config-module-router/pulseaudio-config-module-router_1.0.bb13
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-multimedia/pulseaudio-config-module-router/files/module-router.pa b/recipes-multimedia/pulseaudio-config-module-router/files/module-router.pa
new file mode 100644
index 00000000..4ead26e3
--- /dev/null
+++ b/recipes-multimedia/pulseaudio-config-module-router/files/module-router.pa
@@ -0,0 +1,7 @@
+.ifexists module-router.so
+unload-module module-role-cork
+unload-module module-device-restore
+unload-module module-stream-restore
+unload-module module-card-restore
+load-module module-router
+.endif
diff --git a/recipes-multimedia/pulseaudio-config-module-router/pulseaudio-config-module-router_1.0.bb b/recipes-multimedia/pulseaudio-config-module-router/pulseaudio-config-module-router_1.0.bb
new file mode 100644
index 00000000..710d82fb
--- /dev/null
+++ b/recipes-multimedia/pulseaudio-config-module-router/pulseaudio-config-module-router_1.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "PulseAudio configuration to enable router module"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://module-router.pa"
+
+do_install () {
+ install -d ${D}${sysconfdir}/pulse/default.d
+ install -m 0644 ${WORKDIR}/module-router.pa ${D}${sysconfdir}/pulse/default.d/
+}
+
+RDEPENDS_${PN} = "module-router"
+RPROVIDES_${PN} = "virtual/pulseaudio-config"