summaryrefslogtreecommitdiffstats
path: root/recipes-navigation
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-navigation
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/geoclue/geoclue_agldemo.inc4
-rw-r--r--recipes-navigation/gpsd/gpsd_agldemo.inc10
-rw-r--r--recipes-navigation/osrm-backend/osrm-backend_git.bb2
-rw-r--r--recipes-navigation/protozero/protozero_git.bb2
4 files changed, 9 insertions, 9 deletions
diff --git a/recipes-navigation/geoclue/geoclue_agldemo.inc b/recipes-navigation/geoclue/geoclue_agldemo.inc
index 1e317031e..14f730eea 100644
--- a/recipes-navigation/geoclue/geoclue_agldemo.inc
+++ b/recipes-navigation/geoclue/geoclue_agldemo.inc
@@ -1,9 +1,9 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://geoclue.conf.agl"
PACKAGECONFIG = "nmea lib"
-do_install_append() {
+do_install:append() {
install -D -m 0644 ${WORKDIR}/geoclue.conf.agl ${D}${sysconfdir}/geoclue/geoclue.conf
}
diff --git a/recipes-navigation/gpsd/gpsd_agldemo.inc b/recipes-navigation/gpsd/gpsd_agldemo.inc
index 5899505bc..92303f8b5 100644
--- a/recipes-navigation/gpsd/gpsd_agldemo.inc
+++ b/recipes-navigation/gpsd/gpsd_agldemo.inc
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/gpsd:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/gpsd:"
SRC_URI += "file://sw-device-hook"
-do_install_append() {
+do_install:append() {
# Install device-hook script for starting NMEA output on Sierra Wireless modems
install -d ${D}${sysconfdir}/gpsd
install -m 0755 ${WORKDIR}/sw-device-hook ${D}${sysconfdir}/gpsd/device-hook
@@ -10,11 +10,11 @@ do_install_append() {
-SYSTEMD_SERVICE_${PN}_append = " gpsdctl@.service"
+SYSTEMD_SERVICE:${PN}:append = " gpsdctl@.service"
-RPROVIDES_${PN}-conf_append = " virtual/gpsd-conf"
+RPROVIDES:${PN}-conf:append = " virtual/gpsd-conf"
-do_install_append() {
+do_install:append() {
# use the systemd compatible gpsd.rules
install -d ${D}/${sysconfdir}/udev/rules.d
install -m 0644 ${S}/gpsd.rules ${D}/${sysconfdir}/udev/rules.d/60-gpsd.rules
diff --git a/recipes-navigation/osrm-backend/osrm-backend_git.bb b/recipes-navigation/osrm-backend/osrm-backend_git.bb
index be93e2101..0b5bd3a2f 100644
--- a/recipes-navigation/osrm-backend/osrm-backend_git.bb
+++ b/recipes-navigation/osrm-backend/osrm-backend_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Project-OSRM/osrm-backend.git;protocol=http \
SRCREV = "5b58445535633eb1d6840ef4e8786ff521622867"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/osrm/profiles/*.lua \
${datadir}/osrm/profiles/*/*.lua \
"
diff --git a/recipes-navigation/protozero/protozero_git.bb b/recipes-navigation/protozero/protozero_git.bb
index 3625dcadb..c65968cd9 100644
--- a/recipes-navigation/protozero/protozero_git.bb
+++ b/recipes-navigation/protozero/protozero_git.bb
@@ -15,6 +15,6 @@ SRCREV = "aa8b304cf63831589f52c254b5af2c688bdc2fc4"
S = "${WORKDIR}/git"
-CFLAGS_prepend = " -I${STAGING_DIR_HOST}/include"
+CFLAGS:prepend = " -I${STAGING_DIR_HOST}/include"
inherit cmake pkgconfig