summaryrefslogtreecommitdiffstats
path: root/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-11-18 19:41:27 +0200
committerLeon Anavi <leon.anavi@konsulko.com>2016-11-18 20:12:42 +0200
commit56ebf697eb35021fe32797713b20d92a7c484b2d (patch)
tree5fc7e097fdd08752ac69bc96a35b21654a83a840 /recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
parente499fa0115258d8b35195191c892022486ab48de (diff)
openivi-html5_git.bb: Add OpenIVI Mobility HTML5
OpenIVI Mobility brings HTML5 environment for running web applications on top of AGL. It is powered by QtWebKit therefore the Yocto/OE recipe depends on meta-qt5. Bug-AGL: SPEC-330 Change-Id: I8c16a4082db2e42d8f50403eb43cd1e1c847ac1b Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh')
-rw-r--r--recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh b/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
new file mode 100644
index 000000000..ed8a56144
--- /dev/null
+++ b/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/$UID
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+fi
+
+/usr/bin/openivi-html5 -f -u /usr/share/openivi/example/cluster/index.html