summaryrefslogtreecommitdiffstats
path: root/recipes-openivi/openivi-html5/openivi-html5_git.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2017-05-27 10:45:33 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-30 12:31:55 +0000
commit847493e6b994e25c5936a9534e2e225f9e2a42ad (patch)
tree5781f00e703a7f1ecfc5035f1df142426e48dddd /recipes-openivi/openivi-html5/openivi-html5_git.bb
parente51f84722b85265924d0a74e61598a57bb54fdfe (diff)
openivi-html5: Fix visibility issues
Change the systemd service to user unit, add dependencies, update the bash script for launching openivi-html5 and fix the visibility issue to prevent blank screen at startup. AGL-Bug: SPEC-629 Change-Id: Ibc64088a39a1d7cc2899cb0ff43e8312cde95bc8 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-openivi/openivi-html5/openivi-html5_git.bb')
-rw-r--r--recipes-openivi/openivi-html5/openivi-html5_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-openivi/openivi-html5/openivi-html5_git.bb b/recipes-openivi/openivi-html5/openivi-html5_git.bb
index 11517194..168b98c7 100644
--- a/recipes-openivi/openivi-html5/openivi-html5_git.bb
+++ b/recipes-openivi/openivi-html5/openivi-html5_git.bb
@@ -16,9 +16,7 @@ PV = "0.1"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} = "openivi-html5.service"
-
-RDEPENDS_${PN} = "qtbase qtwebkit"
+RDEPENDS_${PN} = "qtbase qtwebkit inputeventmanager windowmanager"
DEPENDS = "qtbase-native qtbase qtwebkit"
EXTRA_OECMAKE = " -DCMAKE_DISABLE_FIND_PACKAGE_X11=TRUE "
@@ -35,8 +33,11 @@ do_install() {
install -p -D ${WORKDIR}/openivi-html5.sh ${D}${bindir}/openivi-html5.sh
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_unitdir}/system/openivi-html5.service
+ install -d ${D}${systemd_user_unitdir}
+ install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_user_unitdir}/openivi-html5.service
+ install -d ${D}${sysconfdir}/systemd/user/default.target.wants
+ ln -sf ${systemd_user_unitdir}/openivi-html5.service ${D}${sysconfdir}/systemd/user/default.target.wants
fi
}
-FILES_${PN} += " ${prefix}/bin/openivi-html5.sh"
+FILES_${PN} += " ${prefix}/bin/openivi-html5.sh ${systemd_user_unitdir} ${sysconfdir}"