summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-flutter.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-08-15 15:39:21 -0400
committerScott Murray <scott.murray@konsulko.com>2024-08-17 13:48:23 +0000
commit4f0351ed75b5d7384e0e5ec2d6621610d6e51c1a (patch)
tree7eb4d2ac9d70e0cbbf8c85ceec03fb43e9d07d5c /recipes-platform/images/agl-cluster-demo-flutter.bb
parentb656c0db27053e3f2e23dc37c053cd17536b0129 (diff)
Fix Qt cluster demo images
The rework of the demo images done for SPEC-5138 missed some things for the Qt cluster demo images, so add the extra demo vs non-demo configuration file for use in the "preconfigured" image, and update the image recipes to get things work with respect to developer expecations. Additionally: - The databroker access token for cluster-dashboard was out of date, a copy of the one for the Flutter cluster dashboard has been copied in to restore expected behavior. - The Flutter cluster demo has also been tweaked slightly to match the style used in the other image recipes. Bug-AGL: SPEC-5229 Change-Id: I8cc9cfb67c31ace95e6ac36e4259099223f7d802 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30174 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-flutter.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter.bb b/recipes-platform/images/agl-cluster-demo-flutter.bb
index dfa256209..1459893b9 100644
--- a/recipes-platform/images/agl-cluster-demo-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-flutter.bb
@@ -12,6 +12,10 @@ IMAGE_FEATURES += " \
kuksa-val-databroker \
"
+AGL_DEVEL_INSTALL = " \
+ simple-can-simulator \
+"
+
# Generic
IMAGE_INSTALL += "\
weston-ini-conf-landscape \
@@ -19,7 +23,7 @@ IMAGE_INSTALL += "\
packagegroup-agl-networking \
cluster-receiver \
\
- simple-can-simulator \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
"
# Flutter