summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-flutter.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-01 16:57:17 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 13:15:38 +0000
commitea7e39dc258c5e7d3a46ffb31b3321331ba9e900 (patch)
treed48c8892f498323b8b8389839e18017e9ea76b93 /recipes-platform/images/agl-cluster-demo-flutter.bb
parent7069907215c5eaeacc874720b1198d3249cc4b57 (diff)
Replace agl-demo* features with preconfigured images
Changes: - Remove the agl-demo-preload and agl-demo-cluster-support setup features. - Make the agl-weston-remoting setup feature a dependency of the agl-demo feature. To accommodate this with respect to avoiding putting the remote-output display configuration into generated weston.ini files when not required, the logic for that has been moved from meta-agl-core's weston-ini-conf recipe, and extra weston-ini-conf-* packages with the remote output support enabled are now generated to be used in images when required. - Add *-preconfigured versions of the images useful in a full demo setup (i.e. with "green machine" for tradeshows). These images have the configuration tweaks that the build setup features enabled with conditional logic baked in. - Remove now unnecessary connman-conf bbappend, we now assume that the IVI and cluster IP addresses are assigned as 192.168.10.2 and 192.168.10.3 via DHCP in a full demo setup. Notes: - The cluster support in the *-preconfigured images assumes that the IVI board is at IP address 192.168.10.2, and both boards are in the 192.168.10.x subnet. Bug-AGL: SPEC-5138 Change-Id: Icc472c6b602fa8fa5570af6cb0acaef853cbfa0f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29866 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-flutter.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter.bb b/recipes-platform/images/agl-cluster-demo-flutter.bb
index 5cf3daf9f..b2581f87e 100644
--- a/recipes-platform/images/agl-cluster-demo-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-flutter.bb
@@ -7,31 +7,27 @@ require agl-demo-features.inc
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
-# KUKSA.val databroker is not installed with "agl-demo-preload"
-# feature enabled, since demo unit configuration points at the
-# databroker on the IVI board in that setup.
IMAGE_FEATURES += " \
kuksa-val-databroker-client \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+ kuksa-val-databroker \
"
# Generic
IMAGE_INSTALL += "\
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ weston-ini-conf-landscape \
\
packagegroup-agl-networking \
cluster-receiver \
\
simple-can-simulator \
- "
+"
# Flutter
IMAGE_INSTALL += "\
+ flutter-auto \
flutter-cluster-dashboard \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
+ flutter-cluster-dashboard-conf \
cluster-demo-config-flutter \
- flutter-auto \
- "
+"
CLANGSDK = "1"