summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-20 12:29:24 -0500
committerScott Murray <scott.murray@konsulko.com>2024-03-19 02:05:26 +0000
commit3909ee206c177c7130c5d5a5f9b25aaad9897866 (patch)
treeb33257ae992278d1be125475f36310787da3cd91 /recipes-platform/images/agl-cluster-demo-platform.bb
parent98dc1be0341b33d4c4283ffe66b9f5f3bf9185ce (diff)
Add KUKSA.val databroker image features
Rework inclusion of KUKSA.val databroker server and client support into image features that can be specified via IMAGE_FEATURES, and use that in our demo image definitions. As well, add a new agl-kvm-host-kuksa feature that allows configuring the KVM demo build to run the databroker on the host instead of in the IVI guest. Some further application configuration changes are required for that to fully work, those will come in follow up commits. Bug-AGL: SPEC-5082 Change-Id: Ice931fe924c1bf49709999eeabcb998ee191fc80 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29699 ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account (cherry picked from commit 0c14b48d5b0c1129e79f7a59daaedd3f55989c5c) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29760
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index a4992467..c427af66 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "AGL Cluster Demo Platform image currently contains a simple clust
LICENSE = "MIT"
require recipes-platform/images/agl-image-compositor.bb
+require agl-demo-features.inc
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
@@ -10,12 +11,12 @@ inherit features_check
REQUIRED_DISTRO_FEATURES = "wayland"
-# Break out KUKSA.val packages, as demo unit configuration
-# points at KUKSA.val server on the IVI board in full demo
-# builds with the "agl-demo-preload" feature enabled.
-KUKSA_DATABROKER_PACKAGES = " \
- packagegroup-agl-kuksa-val-databroker \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
+# KUKSA.val databroker is not installed with "agl-demo-preload"
+# feature enabled, since demo unit configuration points at the
+# databroker on the IVI board in that setup.
+IMAGE_FEATURES += " \
+ kuksa-val-databroker-client \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
"
# add packages for cluster demo platform (include demo apps) here
@@ -24,6 +25,5 @@ IMAGE_INSTALL += " \
kuksa-certificates-agl-ca \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${KUKSA_DATABROKER_PACKAGES}", d)} \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
"