summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-24 00:20:45 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-24 09:32:31 +0000
commitb5ca98fe204a7ec6f4a1cf84c19ffeb5f4deb128 (patch)
tree14ced4cb4ac47397cf2b98edfbd99f276da7691c /recipes-platform/images/agl-cluster-demo-platform.bb
parent46c474de444f90ab2a81234c507c0514054cb98e (diff)
Explicitly add CA certificate package to cluster images
Explicitly add kuksa-certificates-ca-agl to the cluster demo images so it will be included in both regular and agl-demo-preload builds. Also remove obsolete dependency on kuksa-certificates-client-agl from the cluster-dashboard recipe, and kuksa-databroker RRECOMMENDS from the libqtappfw recipe to fix the regular vs agl-demo-preload behavior for the agl-cluster-demo-platform build. Bug-AGL: SPEC-4986 Change-Id: I62b1d976c66824fde50a3effdcdd34b428e82d54 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29472 ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index 385d7809..a4992467 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -13,7 +13,7 @@ REQUIRED_DISTRO_FEATURES = "wayland"
# Break out KUKSA.val packages, as demo unit configuration
# points at KUKSA.val server on the IVI board in full demo
# builds with the "agl-demo-preload" feature enabled.
-IMAGE_KUKSA_PACKAGES = " \
+KUKSA_DATABROKER_PACKAGES = " \
packagegroup-agl-kuksa-val-databroker \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
"
@@ -21,8 +21,9 @@ IMAGE_KUKSA_PACKAGES = " \
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
+ kuksa-certificates-agl-ca \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${KUKSA_DATABROKER_PACKAGES}", d)} \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
"