summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-qt.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-04-26 10:44:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 20:24:14 +0000
commite3dad1344fee65f54b639f541c7f10352088462b (patch)
treea7606fbf3318d211c5a11fc981a8935a11488233 /recipes-platform/images/agl-cluster-demo-qt.bb
parente62442d3ae45ddb89bc61ced656e682591cc0902 (diff)
Rework demo image naming
Rename the demo images to align with the following scheme: agl-<ivi|cluster|etc>-<image|demo>-<qt|flutter|etc>(-<crosssdk|preconfigured>) The intent is to make the naming more consistent in preparation for switching to preconfigured images as a replacement for the existing agl-demo-preload, agl-demo-cluster-support, agl-kvm-host-* aglsetup.sh features. Additionally, the prototype LXC demo image support has been removed as it is unused and would need updating for these and upcoming changes. Bug-AGL: SPEC-5138 Change-Id: I8d907713b09eb47c3cb0ebd5326ab063b2684ea2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29903 Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-qt.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-qt.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-qt.bb b/recipes-platform/images/agl-cluster-demo-qt.bb
new file mode 100644
index 000000000..c427af66b
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-qt.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "AGL Cluster Demo Platform image currently contains a simple cluster interface."
+
+LICENSE = "MIT"
+
+require recipes-platform/images/agl-image-compositor.bb
+require agl-demo-features.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
+# KUKSA.val databroker is not installed with "agl-demo-preload"
+# feature enabled, since demo unit configuration points at the
+# databroker on the IVI board in that setup.
+IMAGE_FEATURES += " \
+ kuksa-val-databroker-client \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+"
+
+# add packages for cluster demo platform (include demo apps) here
+IMAGE_INSTALL += " \
+ packagegroup-agl-cluster-demo-platform \
+ kuksa-certificates-agl-ca \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
+ "