summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-qt.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-08-15 15:39:21 -0400
committerScott Murray <scott.murray@konsulko.com>2024-08-20 14:21:56 +0000
commit145d8b075a26f9b8810c6b846642db63b462ea38 (patch)
treed14310dabde5557a5db81f1be9e48f9a42ac2f06 /recipes-platform/images/agl-cluster-demo-qt.bb
parentd3856bff8cfc0552eb51d4bf0d4ce72a4d13d4c9 (diff)
Fix Qt cluster demo images
The rework of the demo images done for SPEC-5138 missed some things for the Qt cluster demo images, so add the extra demo vs non-demo configuration file for use in the "preconfigured" image, and update the image recipes to get things work with respect to developer expecations. Additionally: - The databroker access token for cluster-dashboard was out of date, a copy of the one for the Flutter cluster dashboard has been copied in to restore expected behavior. - The Flutter cluster demo has also been tweaked slightly to match the style used in the other image recipes. Bug-AGL: SPEC-5229 Change-Id: I8cc9cfb67c31ace95e6ac36e4259099223f7d802 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30174 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> (cherry picked from commit 4f0351ed75b5d7384e0e5ec2d6621610d6e51c1a) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30202
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-qt.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-qt.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-qt.bb b/recipes-platform/images/agl-cluster-demo-qt.bb
index 03dfb36cc..225fe32c6 100644
--- a/recipes-platform/images/agl-cluster-demo-qt.bb
+++ b/recipes-platform/images/agl-cluster-demo-qt.bb
@@ -16,10 +16,20 @@ IMAGE_FEATURES += " \
kuksa-val-databroker \
"
+# Set up for testing with the databroker when using agl-devel
+AGL_DEVEL_INSTALL = " \
+ cluster-demo-config \
+ simple-can-simulator \
+"
+
+QT_CLUSTER_DASHBOARD_CONF = "cluster-dashboard-conf"
+
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
+ ${QT_CLUSTER_DASHBOARD_CONF} \
kuksa-certificates-agl-ca \
weston-ini-conf-landscape \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
"