summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb')
-rwxr-xr-xrecipes-platform/images/agl-image-graphical-qt5-crosssdk.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
index 5147ea44..596ac80e 100755
--- a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
+++ b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
@@ -4,11 +4,25 @@ DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
It includes the full meta-toolchain, plus developement headers and libraries \
to form a standalone cross SDK."
-require agl-image-graphical-qt5.bb
+#require agl-image-graphical-qt5.bb
+require recipes-platform/images/agl-image-weston.inc
+
LICENSE = "MIT"
-require agl-image-graphical-qt5-crosssdk.inc
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+
+# Add qtwaylandscanner to the SDK
+TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
+
inherit populate_sdk populate_sdk_qt5