summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-01 16:57:17 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-29 10:27:17 +0000
commit18058d1ed6ed4235505870067837a26a4864a117 (patch)
tree132a2cc1452a8c155d2e937a9b6751123bc0f688 /recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
parente3dad1344fee65f54b639f541c7f10352088462b (diff)
Replace agl-demo* features with preconfigured images
Changes: - Remove the agl-demo-preload and agl-demo-cluster-support setup features. - Make the agl-weston-remoting setup feature a dependency of the agl-demo feature. To accommodate this with respect to avoiding putting the remote-output display configuration into generated weston.ini files when not required, the logic for that has been moved from meta-agl-core's weston-ini-conf recipe, and extra weston-ini-conf-* packages with the remote output support enabled are now generated to be used in images when required. - Add *-preconfigured versions of the images useful in a full demo setup (i.e. with "green machine" for tradeshows). These images have the configuration tweaks that the build setup features enabled with conditional logic baked in. - Remove now unnecessary connman-conf bbappend, we now assume that the IVI and cluster IP addresses are assigned as 192.168.10.2 and 192.168.10.3 via DHCP in a full demo setup. Notes: - The cluster support in the *-preconfigured images assumes that the IVI board is at IP address 192.168.10.2, and both boards are in the 192.168.10.x subnet. Bug-AGL: SPEC-5138 Change-Id: Icc472c6b602fa8fa5570af6cb0acaef853cbfa0f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29904 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb')
-rw-r--r--recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
new file mode 100644
index 000000000..7d76f4c7e
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
@@ -0,0 +1,14 @@
+require agl-ivi-demo-flutter.bb
+
+SUMMARY = "AGL IVI preconfigured demo Flutter image"
+
+IMAGE_FEATURES += "agl-demo-cluster-support"
+
+# We do not want weston-terminal visible
+IMAGE_INSTALL:remove = "weston-terminal-conf"
+
+IMAGE_INSTALL += " \
+ weston-ini-conf-remoting \
+ demo-i2c-udev-conf \
+ simple-can-simulator \
+"