summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-ivi-image.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-04-26 10:44:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 20:24:14 +0000
commite3dad1344fee65f54b639f541c7f10352088462b (patch)
treea7606fbf3318d211c5a11fc981a8935a11488233 /recipes-platform/images/agl-ivi-image.bb
parente62442d3ae45ddb89bc61ced656e682591cc0902 (diff)
Rework demo image naming
Rename the demo images to align with the following scheme: agl-<ivi|cluster|etc>-<image|demo>-<qt|flutter|etc>(-<crosssdk|preconfigured>) The intent is to make the naming more consistent in preparation for switching to preconfigured images as a replacement for the existing agl-demo-preload, agl-demo-cluster-support, agl-kvm-host-* aglsetup.sh features. Additionally, the prototype LXC demo image support has been removed as it is unused and would need updating for these and upcoming changes. Bug-AGL: SPEC-5138 Change-Id: I8d907713b09eb47c3cb0ebd5326ab063b2684ea2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29903 Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-ivi-image.bb')
-rw-r--r--recipes-platform/images/agl-ivi-image.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-image.bb b/recipes-platform/images/agl-ivi-image.bb
new file mode 100644
index 000000000..12122cafb
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-image.bb
@@ -0,0 +1,32 @@
+SUMMARY = "AGL IVI demo base image"
+LICENSE = "MIT"
+
+require recipes-platform/images/agl-image-compositor.bb
+
+require agl-ivi-demo-features.inc
+require agl-demo-container-guest-integration.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+AGL_DEVEL_INSTALL += "\
+ simple-can-simulator \
+ unzip \
+ mpc \
+"
+
+AGL_APPS_INSTALL = ""
+
+IMAGE_INSTALL += " \
+ packagegroup-agl-ivi-connectivity \
+ packagegroup-agl-ivi-graphics \
+ packagegroup-agl-ivi-multimedia \
+ packagegroup-agl-ivi-multimedia-hardware \
+ packagegroup-agl-ivi-navigation \
+ packagegroup-agl-ivi-identity \
+ packagegroup-agl-ivi-services-applaunchd \
+ iproute2 \
+ ${AGL_APPS_INSTALL} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-audio", "", "packagegroup-agl-ivi-services-platform", d)} \
+"
+