summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-ivi-image.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-04-26 10:44:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-23 12:13:21 +0000
commit24e22727b7f0c21eeeb62cd536e0c3b25775735b (patch)
treea006b09e21015ba7052202262b868950565506bd /recipes-platform/images/agl-ivi-image.bb
parentbcc5b2bce4992377120de56cf9886abc10d66f6c (diff)
Rework demo image naming
Rename the demo images to align with the following scheme: agl-<ivi|cluster|etc>-<image|demo>-<qt|flutter|etc>(-<crosssdk|preconfigured>) The intent is to make the naming more consistent in preparation for switching to preconfigured images as a replacement for the existing agl-demo-preload, agl-demo-cluster-support, agl-kvm-host-* aglsetup.sh features. Additionally, the prototype LXC demo image support has been removed as it is unused and would need updating for these and upcoming changes. Bug-AGL: SPEC-5138 Change-Id: I8d907713b09eb47c3cb0ebd5326ab063b2684ea2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29864 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-ivi-image.bb')
-rw-r--r--recipes-platform/images/agl-ivi-image.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-image.bb b/recipes-platform/images/agl-ivi-image.bb
new file mode 100644
index 000000000..12122cafb
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-image.bb
@@ -0,0 +1,32 @@
+SUMMARY = "AGL IVI demo base image"
+LICENSE = "MIT"
+
+require recipes-platform/images/agl-image-compositor.bb
+
+require agl-ivi-demo-features.inc
+require agl-demo-container-guest-integration.inc
+
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+AGL_DEVEL_INSTALL += "\
+ simple-can-simulator \
+ unzip \
+ mpc \
+"
+
+AGL_APPS_INSTALL = ""
+
+IMAGE_INSTALL += " \
+ packagegroup-agl-ivi-connectivity \
+ packagegroup-agl-ivi-graphics \
+ packagegroup-agl-ivi-multimedia \
+ packagegroup-agl-ivi-multimedia-hardware \
+ packagegroup-agl-ivi-navigation \
+ packagegroup-agl-ivi-identity \
+ packagegroup-agl-ivi-services-applaunchd \
+ iproute2 \
+ ${AGL_APPS_INSTALL} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-audio", "", "packagegroup-agl-ivi-services-platform", d)} \
+"
+