summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
authorynakamura <ynakamura@jp.adit-jv.com>2016-12-28 14:57:00 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2017-01-25 04:37:42 +0000
commit219e576cc39946ba717ac7c8db5af912a44d3aad (patch)
tree91934c5e0990da6f4274476397d0aa9b18ba1758 /recipes-platform/images
parentfb92e316727a1ad0012ac90ed52c5d9cecdcf433 (diff)
Add switch on/off script for cluster demo
v2.0: (Tadao Tanikawa) Completely rebuilt. The mapviewer and mapvier-demo are installed into porter's image only because they need AGL CES2017 Demo mock-up. To enable mapviewer-demo, execute switch_on_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. CAUTION: After enabling mapviewer-demo, without cluster mock up which connected directly to porter board, weston on the porter board would always crash immediately after booting. If you fall into that situation, disable mapviewer-demo following instructions below. To disable mapviewer-demo, execute switch_off_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. v1.0: (Yusuke Nakamura) This addes script to enable/disable CES2017 cluster demo to /usr/AGL/cluster-demo. Once switch_on_cluster-demo.sh is executed, this enables a service for cluster demo and sets configurations for the dmeo. Change-Id: Ie10f35ff4168095c3b3c6572579a2c4799c04578 Signed-off-by: ynakamura <ynakamura@jp.adit-jv.com> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-demo-platform.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index 4fd141c6..2c9047e1 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -52,6 +52,13 @@ IMAGE_MOST_HVAC_append_porter = " \
can-lin \
"
+# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
+IMAGE_MAPVIEWER = " "
+IMAGE_MAPVIEWER_append_porter = " \
+ mapviewer \
+ mapviewer-demo \
+ "
+
IMAGE_AGL_APPS = " \
hvac \
mediaplayer \
@@ -70,7 +77,7 @@ IMAGE_INSTALL_append = " \
dhcp-client \
navigation \
poiapp \
- mapviewer \
+ ${IMAGE_MAPVIEWER} \
${IMAGE_MOST_HVAC} \
${IMAGE_AGL_APPS} \
${IMAGE_TTF_FONTS} \