summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:20:22 -0500
commit12ad591d3038db609db5290d8bbe809a34c743de (patch)
treedbbcc9a44134a012f531d48132c8803c3940bfa2 /recipes-platform/images
parent88c424f8b8c78dfc5520ea9be1866027df4735b8 (diff)
This is effectively a manual cherry-pick and squash of commits: 4249268041b879b3d2bae338d5de88f4f2d54b26 07f4ab8c2833ae5377b97cc9e3820bed67e539d0 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3b47f1b7d62038b314a17763d24a64f6d4e15e72
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb8
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb4
-rw-r--r--recipes-platform/images/agl-cluster-demo-qtcompositor.bb4
-rw-r--r--recipes-platform/images/agl-demo-platform-html5.bb4
-rw-r--r--recipes-platform/images/agl-demo-platform-qa.bb2
-rw-r--r--recipes-platform/images/agl-demo-platform.bb6
-rw-r--r--recipes-platform/images/agl-image-cluster-qt5.bb2
-rw-r--r--recipes-platform/images/agl-image-cluster.bb2
-rw-r--r--recipes-platform/images/agl-image-graphical-html5.bb2
-rw-r--r--recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc6
-rw-r--r--recipes-platform/images/agl-image-ivi-qa.bb2
-rw-r--r--recipes-platform/images/agl-image-ivi.inc2
-rw-r--r--recipes-platform/images/agl-image-telematics.bb2
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb6
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform.bb4
15 files changed, 28 insertions, 28 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb b/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
index 6f8bf6297..8251272cb 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
@@ -8,8 +8,8 @@ require agl-cluster-demo-platform.bb
LICENSE = "MIT"
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+IMAGE_FEATURES:append = " dev-pkgs"
+IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
inherit populate_sdk populate_sdk_qt5
@@ -22,6 +22,6 @@ addtask do_populate_sdk after do_rootfs
# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
# wayland-scanner is in nativesdk-wayland-dev !
# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index ac31ae326..2e8be720c 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -4,10 +4,10 @@ require agl-cluster-demo-platform.inc
LICENSE = "MIT"
-IMAGE_FEATURES_append = ""
+IMAGE_FEATURES:append = ""
# add packages for cluster demo platform (include demo apps) here
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-cluster-demo-platform \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-dashboard-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
diff --git a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb b/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
index d6f325662..0e9afb9c2 100644
--- a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
+++ b/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
@@ -5,11 +5,11 @@ require agl-cluster-demo-qtcompositor.inc
LICENSE = "MIT"
-IMAGE_FEATURES_append = " \
+IMAGE_FEATURES:append = " \
"
# add packages for cluster demo qtcompositor
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-cluster-demo-qtcompositor \
"
diff --git a/recipes-platform/images/agl-demo-platform-html5.bb b/recipes-platform/images/agl-demo-platform-html5.bb
index 2d3490fda..a78b8b68b 100644
--- a/recipes-platform/images/agl-demo-platform-html5.bb
+++ b/recipes-platform/images/agl-demo-platform-html5.bb
@@ -5,10 +5,10 @@ require agl-demo-platform.inc
LICENSE = "MIT"
-IMAGE_FEATURES_append = " \
+IMAGE_FEATURES:append = " \
"
# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform-html5 \
"
diff --git a/recipes-platform/images/agl-demo-platform-qa.bb b/recipes-platform/images/agl-demo-platform-qa.bb
index fa3f717d9..05598ca79 100644
--- a/recipes-platform/images/agl-demo-platform-qa.bb
+++ b/recipes-platform/images/agl-demo-platform-qa.bb
@@ -7,7 +7,7 @@ LICENSE = "MIT"
require agl-demo-platform.bb
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-ivi-common-test \
packagegroup-agl-demo-platform-qa \
"
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index c5a1edb22..5643d4dad 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -7,13 +7,13 @@ LICENSE = "MIT"
# The demo will not work on the pi3 due to the gfx memory
# and the applications requiring FHD (SPEC-390)
-COMPATIBLE_MACHINE_raspberrypi3 = "(^$)"
+COMPATIBLE_MACHINE:raspberrypi3 = "(^$)"
# Always include the test widgets
-IMAGE_FEATURES_append = " agl-test-wgt"
+IMAGE_FEATURES:append = " agl-test-wgt"
# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform \
distro-build-manifest \
"
diff --git a/recipes-platform/images/agl-image-cluster-qt5.bb b/recipes-platform/images/agl-image-cluster-qt5.bb
index 244e2ba48..ec4c9876d 100644
--- a/recipes-platform/images/agl-image-cluster-qt5.bb
+++ b/recipes-platform/images/agl-image-cluster-qt5.bb
@@ -4,6 +4,6 @@ require agl-image-cluster-qt5.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
profile-cluster-qt5 \
"
diff --git a/recipes-platform/images/agl-image-cluster.bb b/recipes-platform/images/agl-image-cluster.bb
index 552d7a74e..c4e33e332 100644
--- a/recipes-platform/images/agl-image-cluster.bb
+++ b/recipes-platform/images/agl-image-cluster.bb
@@ -4,6 +4,6 @@ require agl-image-cluster.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
profile-cluster \
"
diff --git a/recipes-platform/images/agl-image-graphical-html5.bb b/recipes-platform/images/agl-image-graphical-html5.bb
index 0ec6829ed..4ca67634a 100644
--- a/recipes-platform/images/agl-image-graphical-html5.bb
+++ b/recipes-platform/images/agl-image-graphical-html5.bb
@@ -4,7 +4,7 @@ require agl-image-graphical-html5.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-profile-graphical-html5 \
"
diff --git a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
index f43bb07d7..760cbac05 100644
--- a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
+++ b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
@@ -6,9 +6,9 @@ TOOLCHAIN_TARGET_TASK += "libafb-helpers-qt-staticdev"
# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
# wayland-scanner is in nativesdk-wayland-dev !
# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
# Add qtwaylandscanner to the SDK
-TOOLCHAIN_HOST_TASK_append = " nativesdk-qtwayland-tools "
+TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
diff --git a/recipes-platform/images/agl-image-ivi-qa.bb b/recipes-platform/images/agl-image-ivi-qa.bb
index 017439454..2a1dd1a09 100644
--- a/recipes-platform/images/agl-image-ivi-qa.bb
+++ b/recipes-platform/images/agl-image-ivi-qa.bb
@@ -7,7 +7,7 @@ require agl-image-ivi.bb
LICENSE = "MIT"
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-test \
packagegroup-ivi-common-test \
"
diff --git a/recipes-platform/images/agl-image-ivi.inc b/recipes-platform/images/agl-image-ivi.inc
index 7f4d39380..0f6b1e553 100644
--- a/recipes-platform/images/agl-image-ivi.inc
+++ b/recipes-platform/images/agl-image-ivi.inc
@@ -1,6 +1,6 @@
require recipes-platform/images/agl-image-minimal.inc
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-image-ivi \
packagegroup-agl-ivi-services \
agl-service-homescreen \
diff --git a/recipes-platform/images/agl-image-telematics.bb b/recipes-platform/images/agl-image-telematics.bb
index ad6ef9888..94dd60986 100644
--- a/recipes-platform/images/agl-image-telematics.bb
+++ b/recipes-platform/images/agl-image-telematics.bb
@@ -4,6 +4,6 @@ require agl-image-telematics.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
profile-telematics \
"
diff --git a/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb b/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb
index 75b4f5ce1..a3efec425 100644
--- a/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb
@@ -8,8 +8,8 @@ require agl-telematics-demo-platform.bb
LICENSE = "MIT"
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+IMAGE_FEATURES:append = " dev-pkgs"
+IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
inherit populate_sdk
@@ -18,4 +18,4 @@ inherit populate_sdk
# can failed (randomly).
addtask do_populate_sdk after do_rootfs
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
diff --git a/recipes-platform/images/agl-telematics-demo-platform.bb b/recipes-platform/images/agl-telematics-demo-platform.bb
index 403f4b702..41ae11b33 100644
--- a/recipes-platform/images/agl-telematics-demo-platform.bb
+++ b/recipes-platform/images/agl-telematics-demo-platform.bb
@@ -4,10 +4,10 @@ require agl-telematics-demo-platform.inc
LICENSE = "MIT"
-IMAGE_FEATURES_append = " \
+IMAGE_FEATURES:append = " \
"
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-agl-telematics-demo-platform \
"