summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 18:06:42 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:00:05 -0400
commit78883948a2f9ee25ebc24c6fcfefd031d0d3cb6f (patch)
tree16404d69184c0005595873c88cf076598f72ae7d /recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
parentbd151bb0aa5d5492839fa23a8872014e67425771 (diff)
Rework demo packagegroup and images
Rework the agl-ivi-demo-platform* images to reduce duplication, and move the additions for the agl-demo-cluster-support and agl-demo-preload features. Changes: - Pull in agl-image-ivi.bb in the crosssdk image rather than duplicating its contents. This means the package additions from the demo features will be reflected in the SDK, which seems more in line with general expectations of how Yocto SDKs work. - New packagegroups are created for the agl-demo-cluster-support and agl-demo-preload features, and they are pulled into the agl-ivi-demo-platform / agl-demo-platform image using features in IMAGE_FEATURES. This avoids changing the contents of various packagegroups based on AGL_FEATURES and seems more futureproof with respect to binary packaging. - ALLOW_EMPTY has been removed in a few packagegroup recipes, as it does not seem to make sense if the packagegroup will never be empty. - The cluster-dashboard-demo-config recipe pulled into the agl-demo-cluster-support packagegroup has been added back, it was accidentally removed in the application framework cleanup. Bug-AGL: SPEC-4424 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Icaa38651a1d29de09bb40576c773e3f93ee87098
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb25
1 files changed, 1 insertions, 24 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 7c5851c3..06df05ec 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -8,26 +8,14 @@ inherit packagegroup
PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-demo-platform-html5 \
- packagegroup-agl-demo-platform-html5-devel \
"
-ALLOW_EMPTY:${PN} = "1"
-
RDEPENDS:${PN} += "\
packagegroup-agl-image-ivi \
- "
-
-RDEPENDS:${PN} += "\
packagegroup-agl-profile-graphical-html5 \
packagegroup-agl-demo \
"
-
-RDEPENDS:${PN}:append = " \
- weston-ini-conf-landscape \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
- "
-
# TODO(jdapena): replace this with HTML5 apps.
AGL_APPS = " \
html5-dashboard \
@@ -39,21 +27,10 @@ AGL_APPS = " \
html5-settings \
"
-# TODO(jdapena): review if we still need the demo-i2c stuff.
-
-# Hook for demo platform configuration
-# ATM used for:
-# 1) Adding udev configuration and scripts for supporting USB attached
-# I2C devices for RTC and HVAC LED support.
-DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
-
-# Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
-
RDEPENDS:${PN}:append = " \
+ weston-ini-conf-landscape \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
${AGL_APPS} \
- ${DEMO_PRELOAD} \
"