summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 6fec1fc5..baffeb29 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -23,38 +23,6 @@ RDEPENDS:${PN} += "\
packagegroup-agl-demo \
"
-AGL_APPS = " \
- dashboard \
- hvac \
- mediaplayer \
- virtual/navigation \
- phone \
- poiapp \
- radio \
- settings \
- messaging \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
- ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin' , '', d)} \
- virtual/mixer \
- virtual/qtwayland-config \
- "
-
-QTAGLEXTRAS = " libqtappfw"
-
-# add support for websocket in Qt and QML
-QTAGLEXTRAS:append = " qtwebsockets qtwebsockets-qmlplugins"
-#PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
-
-# Cluster demo support.
-# ATM no cluster map viewer is supported with the older navigation application.
-MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
-CLUSTER_SUPPORT_PACKAGES = " \
- ${MAPVIEWER} \
- cluster-demo-network-config \
- cluster-lin-bridging-config \
- cluster-demo-simulator \
-"
-CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
DEMO_UNIT_CONF ?= ""
# Hook for demo platform configuration
@@ -71,9 +39,6 @@ RDEPENDS:${PN}:append = " \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
- ${AGL_APPS} \
- ${QTAGLEXTRAS} \
- ${CLUSTER_SUPPORT} \
${DEMO_PRELOAD} \
"
@@ -84,15 +49,4 @@ RDEPENDS:${PN}:append = " \
# names from the virtual/ RPROVIDES at present.
RDEPENDS:${PN}-devel = " \
packagegroup-hmi-framework-devel \
- dashboard-dbg \
- hvac-dbg \
- mediaplayer-dbg \
- mixer-dbg \
- phone-dbg \
- ondemandnavi-dbg \
- poiapp-dbg \
- radio-dbg \
- settings-dbg \
- messaging-dbg \
- taskmanager-dbg \
"