summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-04-28 21:11:32 +0000
committerScott Murray <scott.murray@konsulko.com>2020-05-08 13:31:03 -0400
commitd11b688e620f042b4c19e3fcfa0aa9970b3624f5 (patch)
tree767bf47004567389fc9e0ae54e19e1826c0bc4f5 /recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
parent69d40194167df655116115f8864251594dbc8744 (diff)
Widget packaging rework
Changes include: - Add "agl-test-wgt" to IMAGE_FEATURES in the agl-demo template definition to yield the desired default behavior of the test widgets always being added to the agl-demo-platform image. - Created new devel and test packagegroup variants for several of the existing packagegroups to contain the associated widgets. - Added several services to the RDEPENDS in the definition of packagegroup-agl-ive-services that have been getting picked up by application RDEPENDS. This simplifies the test/devel packagegroup definitions. - Extend the agl-devel-wgt and agl-test-wgt FEATURE_PACKAGES variables as necessary to add the required corresponding widget packagegroups. - Shifted some non-applications and the use of packagegroup-hmi-framework around a bit in the definition of packagegroup-agl-demo-platform to improve clarity. - The alexa-viewer app and virtual/alexa-voiceagent-config package are now pulled in by extending the agl-voiceagent-alexa FEATURE_PACKAGES definition. This is a cleaner use of the image feature than the previous checking of IMAGE_FEATURES that was being done in the packagegroup-agl-demo-platform definition. Bug-AGL: SPEC-3300 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0ace2d140fdceb1e0d778a0fe71d7f856a953ae4
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb52
1 files changed, 33 insertions, 19 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
index 8d0d74b1..1599299e 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -1,29 +1,43 @@
-DESCRIPTION = "The minimal set of packages for AGL IVI Connectivity Subsystem"
+DESCRIPTION = "The minimal set of services to support AGL IVI demo"
LICENSE = "MIT"
inherit packagegroup
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-ivi-services \
+ packagegroup-agl-ivi-services-test \
+ packagegroup-agl-ivi-services-devel \
"
-ALLOW_EMPTY_${PN} = "1"
-
RDEPENDS_${PN} += "\
-agl-service-bluetooth \
-agl-service-bluetooth-map \
-agl-service-bluetooth-pbap \
-agl-service-can-low-level \
-agl-service-geoclue \
-agl-service-geofence \
-agl-service-gps \
-agl-service-identity-agent \
-agl-service-iiodevices \
-agl-service-mediascanner \
-agl-service-navigation \
-agl-service-nfc \
-agl-service-signal-composer \
-agl-service-steering-wheel \
-agl-service-unicens \
-agl-service-weather \
+ agl-service-bluetooth \
+ agl-service-bluetooth-map \
+ agl-service-bluetooth-pbap \
+ agl-service-can-low-level \
+ agl-service-geoclue \
+ agl-service-geofence \
+ agl-service-gps \
+ agl-service-hvac \
+ agl-service-identity-agent \
+ agl-service-iiodevices \
+ agl-service-mediascanner \
+ agl-service-navigation \
+ agl-service-nfc \
+ agl-service-signal-composer \
+ agl-service-steering-wheel \
+ agl-service-telephony \
+ agl-service-unicens \
+ agl-service-unicens-controller \
+ agl-service-weather \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'agl-service-taskmanager', '', d)} \
+ "
+
+RDEPENDS_${PN}-test = "\
+ ${@' '.join([x + '-test' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
+ "
+
+RDEPENDS_${PN}-devel = "\
+ ${@' '.join([x + '-dbg' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
+ ${@' '.join([x + '-coverage' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
"