summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-16 18:24:25 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-27 21:28:34 +0000
commitb26515dcf2afc510cc59782f99965f10b96be433 (patch)
tree60cb8103f410306171ae487bd4784b0363403297 /recipes-platform
parent2e0fd28b2470f6d81bfb1b0b273af5742060ed6a (diff)
Add gateway demo
Changes: - Add recipe for AGL VSS to MQTT proxy daemon - Update agl-vcar.dbc CAN database definition to add signals useful for demoing the proxy (per V2C EG discussion). - Add a patch to kuksa-dbc-feeder to allow sensor signal updates to generate CAN messages in output mode. - Add VSS vspec variants to define the desired CAN input and output support for the various kuksa-dbc-feeder instances in the default and full gateway demos. - Add configurations for kuksa-dbc-feeder for the running the default gateway demo with CAN output from a demo control panel instance on a single CAN interface, as well as a fuller setup with a second kuksa-dbc-feeder running against a second CAN interface on the gateway to handle the demo steering wheel and HVAC support. - Add gateway demo specific configuration files for various KUKSA.val databroker clients to override the databroker location. - Add agl-gateway-demo and agl-gateway-demo-preconfigured images for the default and full demos. - Add *-preconfigured-gateway image flavors for the Flutter IVI, IC, and KVM demo images that support running with the databroker on the gateway. NOTES: - The *-preconfigured-gateway images assume the gateway has an IP address of 192.168.10.4. - Required changes to the agl-demo-control-panel application and the addition of a agl-ivi-demo-control-panel-preconfigured-gateway image will come in a subsequent change. Bug-AGL: SPEC-5107, SPEC-5138 Change-Id: I9797aa72737af7af3d791a5151198f80b6d90e0d Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29921 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb8
-rw-r--r--recipes-platform/images/agl-gateway-demo-preconfigured.bb10
-rw-r--r--recipes-platform/images/agl-gateway-demo.bb24
-rw-r--r--recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb14
4 files changed, 56 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb
new file mode 100644
index 00000000..767d339c
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb
@@ -0,0 +1,8 @@
+require agl-cluster-demo-flutter-preconfigured.bb
+
+SUMMARY = "AGL Cluster preconfigured gateway demo Flutter image"
+
+# Cluster application configuration needs to be replaced for
+# the full demo to handle different databroker configuration.
+FLUTTER_CLUSTER_DASHBOARD_CONF = "flutter-cluster-dashboard-conf-gateway-demo"
+
diff --git a/recipes-platform/images/agl-gateway-demo-preconfigured.bb b/recipes-platform/images/agl-gateway-demo-preconfigured.bb
new file mode 100644
index 00000000..4a9cf0b2
--- /dev/null
+++ b/recipes-platform/images/agl-gateway-demo-preconfigured.bb
@@ -0,0 +1,10 @@
+require agl-gateway-demo.bb
+
+SUMMARY = "AGL gateway preconfigured demo image"
+
+# Second CAN interface will be connected to the demo setup
+# steering wheel & HVAC in the full demo.
+IMAGE_INSTALL += " \
+ kuksa-dbc-feeder-conf-gw-hardware \
+ vss-agl-gw-hardware \
+"
diff --git a/recipes-platform/images/agl-gateway-demo.bb b/recipes-platform/images/agl-gateway-demo.bb
new file mode 100644
index 00000000..1e800c54
--- /dev/null
+++ b/recipes-platform/images/agl-gateway-demo.bb
@@ -0,0 +1,24 @@
+SUMMARY = "AGL gateway demo image"
+
+LICENSE = "MIT"
+
+require recipes-platform/images/agl-image-minimal.bb
+require agl-demo-features.inc
+
+IMAGE_FEATURES += " \
+ kuksa-val-databroker \
+ ssh-server-openssh \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'can-test-tools' , '', d)} \
+"
+
+AGL_DEVEL_INSTALL = " \
+ packagegroup-agl-kuksa-val-databroker-devel \
+ tcpdump \
+"
+
+IMAGE_INSTALL += " \
+ agl-vss-proxy \
+ kuksa-dbc-feeder-conf-gw-control-panel \
+ vss-agl-gw-control-panel \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '${AGL_DEVEL_INSTALL}', '', d)} \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb
new file mode 100644
index 00000000..1bbd483b
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb
@@ -0,0 +1,14 @@
+require agl-ivi-demo-flutter-preconfigured.bb
+
+SUMMARY = "AGL IVI preconfigured gateway demo Flutter image"
+
+# We do not want a local databroker instance
+IMAGE_FEATURES:remove = "kuksa-val-databroker"
+
+FLUTTER_ICS_HOMESCREEN_CONF = "flutter-ics-homescreen-conf-gateway-demo"
+ONDEMANDNAVI_CONF = "ondemandnavi-conf-gateway-demo"
+
+IMAGE_INSTALL += " \
+ agl-service-hvac-conf-gateway-demo \
+ agl-service-audiomixer-conf-gateway-demo \
+" \ No newline at end of file