summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-01 16:57:17 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 13:15:38 +0000
commitea7e39dc258c5e7d3a46ffb31b3321331ba9e900 (patch)
treed48c8892f498323b8b8389839e18017e9ea76b93 /recipes-platform
parent7069907215c5eaeacc874720b1198d3249cc4b57 (diff)
Replace agl-demo* features with preconfigured images
Changes: - Remove the agl-demo-preload and agl-demo-cluster-support setup features. - Make the agl-weston-remoting setup feature a dependency of the agl-demo feature. To accommodate this with respect to avoiding putting the remote-output display configuration into generated weston.ini files when not required, the logic for that has been moved from meta-agl-core's weston-ini-conf recipe, and extra weston-ini-conf-* packages with the remote output support enabled are now generated to be used in images when required. - Add *-preconfigured versions of the images useful in a full demo setup (i.e. with "green machine" for tradeshows). These images have the configuration tweaks that the build setup features enabled with conditional logic baked in. - Remove now unnecessary connman-conf bbappend, we now assume that the IVI and cluster IP addresses are assigned as 192.168.10.2 and 192.168.10.3 via DHCP in a full demo setup. Notes: - The cluster support in the *-preconfigured images assumes that the IVI board is at IP address 192.168.10.2, and both boards are in the 192.168.10.x subnet. Bug-AGL: SPEC-5138 Change-Id: Icc472c6b602fa8fa5570af6cb0acaef853cbfa0f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29866 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter-preconfigured.bb20
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter.bb16
-rw-r--r--recipes-platform/images/agl-cluster-demo-qt-preconfigured.bb18
-rw-r--r--recipes-platform/images/agl-cluster-demo-qt.bb10
-rw-r--r--recipes-platform/images/agl-ivi-demo-features.inc8
-rw-r--r--recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb14
-rw-r--r--recipes-platform/images/agl-ivi-demo-qt-preconfigured.bb14
-rw-r--r--recipes-platform/images/agl-ivi-demo-qt.bb2
-rw-r--r--recipes-platform/images/agl-ivi-image-flutter.bb2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb23
10 files changed, 78 insertions, 49 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter-preconfigured.bb b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured.bb
new file mode 100644
index 00000000..5532c3e5
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured.bb
@@ -0,0 +1,20 @@
+require agl-cluster-demo-flutter.bb
+
+SUMMARY = "AGL Cluster preconfigured demo Flutter image"
+
+# We do not want a local databroker instance
+IMAGE_FEATURES:remove = "kuksa-val-databroker"
+
+# The cluster screen is rotated in the full demo setup, so the
+# default compositor configuration needs to be replaced.
+IMAGE_INSTALL:remove = "weston-ini-conf-landscape"
+
+# Cluster application configuration needs to be replaced for
+# the full demo to handle different databroker configuration.
+IMAGE_INSTALL:remove = "flutter-cluster-dashboard-conf"
+
+IMAGE_INSTALL += " \
+ psplash-inverted-config \
+ weston-ini-conf-landscape-inverted \
+ flutter-cluster-dashboard-conf-demo \
+"
diff --git a/recipes-platform/images/agl-cluster-demo-flutter.bb b/recipes-platform/images/agl-cluster-demo-flutter.bb
index 5cf3daf9..b2581f87 100644
--- a/recipes-platform/images/agl-cluster-demo-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-flutter.bb
@@ -7,31 +7,27 @@ require agl-demo-features.inc
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
-# KUKSA.val databroker is not installed with "agl-demo-preload"
-# feature enabled, since demo unit configuration points at the
-# databroker on the IVI board in that setup.
IMAGE_FEATURES += " \
kuksa-val-databroker-client \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+ kuksa-val-databroker \
"
# Generic
IMAGE_INSTALL += "\
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ weston-ini-conf-landscape \
\
packagegroup-agl-networking \
cluster-receiver \
\
simple-can-simulator \
- "
+"
# Flutter
IMAGE_INSTALL += "\
+ flutter-auto \
flutter-cluster-dashboard \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
+ flutter-cluster-dashboard-conf \
cluster-demo-config-flutter \
- flutter-auto \
- "
+"
CLANGSDK = "1"
diff --git a/recipes-platform/images/agl-cluster-demo-qt-preconfigured.bb b/recipes-platform/images/agl-cluster-demo-qt-preconfigured.bb
new file mode 100644
index 00000000..c993406c
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-qt-preconfigured.bb
@@ -0,0 +1,18 @@
+require agl-cluster-demo-qt.bb
+
+SUMMARY = "AGL Cluster preconfigured demo Qt image"
+
+# We do not want a local databroker instance
+IMAGE_FEATURES:remove = "kuksa-val-databroker"
+
+# We do not want weston-terminal visible
+IMAGE_INSTALL:remove = "weston-terminal-conf"
+
+# The cluster screen is rotated in the full demo setup, so the
+# default compositor configuration needs to be replaced.
+IMAGE_INSTALL:remove = "weston-ini-conf-landscape"
+
+IMAGE_INSTALL += " \
+ cluster-demo-config \
+ weston-ini-conf-landscape-inverted \
+"
diff --git a/recipes-platform/images/agl-cluster-demo-qt.bb b/recipes-platform/images/agl-cluster-demo-qt.bb
index c427af66..03dfb36c 100644
--- a/recipes-platform/images/agl-cluster-demo-qt.bb
+++ b/recipes-platform/images/agl-cluster-demo-qt.bb
@@ -11,19 +11,15 @@ inherit features_check
REQUIRED_DISTRO_FEATURES = "wayland"
-# KUKSA.val databroker is not installed with "agl-demo-preload"
-# feature enabled, since demo unit configuration points at the
-# databroker on the IVI board in that setup.
IMAGE_FEATURES += " \
kuksa-val-databroker-client \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+ kuksa-val-databroker \
"
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
kuksa-certificates-agl-ca \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ weston-ini-conf-landscape \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
- "
+"
diff --git a/recipes-platform/images/agl-ivi-demo-features.inc b/recipes-platform/images/agl-ivi-demo-features.inc
index 9aabaafe..ecf3cd98 100644
--- a/recipes-platform/images/agl-ivi-demo-features.inc
+++ b/recipes-platform/images/agl-ivi-demo-features.inc
@@ -1,7 +1,5 @@
require agl-demo-features.inc
-FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
-
FEATURE_PACKAGES_agl-demo-cluster-support = " \
tbtnavi \
${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-kuksa", "tbtnavi-conf-kvm-demo", "tbtnavi-conf", d)} \
@@ -9,11 +7,7 @@ FEATURE_PACKAGES_agl-demo-cluster-support = " \
"
IMAGE_FEATURES += " \
- ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "can-test-tools" , "", d)} \
- ${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)} \
-"
-
-IMAGE_FEATURES += " \
kuksa-val-databroker-client \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "can-test-tools" , "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-kuksa", "", "kuksa-val-databroker", d)} \
"
diff --git a/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
new file mode 100644
index 00000000..7d76f4c7
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured.bb
@@ -0,0 +1,14 @@
+require agl-ivi-demo-flutter.bb
+
+SUMMARY = "AGL IVI preconfigured demo Flutter image"
+
+IMAGE_FEATURES += "agl-demo-cluster-support"
+
+# We do not want weston-terminal visible
+IMAGE_INSTALL:remove = "weston-terminal-conf"
+
+IMAGE_INSTALL += " \
+ weston-ini-conf-remoting \
+ demo-i2c-udev-conf \
+ simple-can-simulator \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-qt-preconfigured.bb b/recipes-platform/images/agl-ivi-demo-qt-preconfigured.bb
new file mode 100644
index 00000000..fa1313e8
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-qt-preconfigured.bb
@@ -0,0 +1,14 @@
+require agl-ivi-demo-qt.bb
+
+SUMMARY = "AGL IVI preconfigured demo Qt image"
+
+IMAGE_FEATURES += "agl-demo-cluster-support"
+
+# We do not want weston-terminal visible
+IMAGE_INSTALL:remove = "weston-terminal-conf"
+
+IMAGE_INSTALL += " \
+ weston-ini-conf-remoting \
+ demo-i2c-udev-conf \
+ simple-can-simulator \
+" \ No newline at end of file
diff --git a/recipes-platform/images/agl-ivi-demo-qt.bb b/recipes-platform/images/agl-ivi-demo-qt.bb
index 2f0e9427..79640791 100644
--- a/recipes-platform/images/agl-ivi-demo-qt.bb
+++ b/recipes-platform/images/agl-ivi-demo-qt.bb
@@ -18,6 +18,6 @@ AGL_APPS_INSTALL += " \
IMAGE_INSTALL += " \
packagegroup-agl-demo-platform \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
+ weston-terminal-conf \
"
diff --git a/recipes-platform/images/agl-ivi-image-flutter.bb b/recipes-platform/images/agl-ivi-image-flutter.bb
index 56a8b2f8..0c227f0e 100644
--- a/recipes-platform/images/agl-ivi-image-flutter.bb
+++ b/recipes-platform/images/agl-ivi-image-flutter.bb
@@ -4,5 +4,5 @@ SUMMARY = "AGL IVI demo base Flutter image"
IMAGE_INSTALL += " \
packagegroup-agl-demo-platform-flutter \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
+ weston-terminal-conf \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
deleted file mode 100644
index 808c93c6..00000000
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "Extra software and configuration for tradeshow demo with AGL IVI profile demo platform"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PROVIDES = "${PACKAGES}"
-PACKAGES = " \
- packagegroup-agl-demo-preload \
-"
-
-# NOTES:
-# - demo-i2c-udev-conf:
-# Adds udev configuration and scripts for supporting USB attached
-# I2C devices for RTC and HVAC LED support.
-# - simple-can-simulator:
-# CAN message simulator for vehicle and engine speed message
-# generation, with some support for the cruise control events from
-# the steering wheel used in the demo setup.
-#
-RDEPENDS:${PN} = "\
- demo-i2c-udev-conf \
- simple-can-simulator \
-"