summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-18 21:48:59 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-19 03:06:37 +0000
commitf1d90e941910c50b7ea1e9b8a6119d31c308e67d (patch)
tree2fd6c3247f8ff4ac985f6dac6e4fa53d54881f06 /recipes-platform
parent4091efd9ed80566bf9e3cbba6a414431462a4c27 (diff)
Add udev rules and scripts for demo platform configuration
Add recipes for udev rules and associated scripts provided by Jan-Simon Möller to: 1) Support USB attached I2C devices for RTC and HVAC LED support. The RTC support loads and configures the required rtc-ds1307 driver, and sets the time from the RTC clock. The HVAC LED support configures the LED device names for use by the HVAC binding. 2) Detect Fiberdyne MOST attached amp and install the required 4A HAL. The new demo-i2c-udev-conf and demo-most-udev-conf recipes are added to DEMO_PLATFORM_CONF variable in packagegroup-agl-demo-platform to have them added to the agl-demo-platform image. Since they use udev rules to detect the corresponding hardware, this should be safe for all platforms. Change-Id: I9dc78b8e63418079d14e1d1e2a832840a0c97ea8 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index d7dddb7d..1552558f 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -66,10 +66,18 @@ DEMO_MAPS_LOCALE ?= "uk"
DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
# Hook for demo platform configuration
-# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
-# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+# ATM used for:
+# 1) Adding udev configuration and scripts for supporting USB attached
+# I2C devices for RTC and HVAC LED support.
+# 2) Adding udev configuration and script for detecting Fiberdyne MOST
+# attached amp and installing the required 4A HAL.
+# 3) Disabling btwilink module on M3ULCB + Kingfisher by default. To
+# re-enable, set DEMO_ENABLE_BTWILINK to "true" in local.conf/site.conf.
DEMO_ENABLE_BTWILINK ?= ""
-DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF = " \
+ demo-i2c-udev-conf \
+ demo-most-udev-conf \
+"
DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
RDEPENDS_${PN}_append = " \