summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-10-01 11:56:02 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-07 16:18:49 +0000
commit31bee85678d793fb06af42d260711e02d882dc78 (patch)
tree778debb2958122ef96eb2a2bc34902ed64de45d4 /recipes-platform
parent3fe7f283824a7afb6ffe22a904d57b28a9b69a72 (diff)
Refactor packagegroup to enable sllin on h3
Remove the restriction to only add sllin on m3 as we're moving to the h3 in the demo. v2: make the settings adjustable in local.conf and remove comment. Bug-AGL: SPEC-2826 Change-Id: I09ea14934e3714daba6e94c81902453872ce1aa9 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> (cherry picked from commit 9b02ca4c8ea81bba23f97b7eb1e8fe200102a9eb)
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb29
1 files changed, 19 insertions, 10 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 21ad20a8..267a0d28 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -20,22 +20,29 @@ RDEPENDS_${PN} += "\
packagegroup-agl-demo \
"
-MOST_DRIVERS = " \
+# MOST out-of-tree kernel drivers
+#################################
+MOST_DRIVERS ??= " \
most \
"
-MOST_DRIVERS_append_m3ulcb = " sllin"
+# These boards use different kernels - needs to be checked
+MOST_DRIVERS_dra7xx-evm ?= ""
+MOST_DRIVERS_dragonboard-410c ?= ""
-# HVAC dependencies depend on drivers above
-MOST_HVAC = " "
-MOST_HVAC_append = " \
- ${MOST_DRIVERS} \
+
+# HVAC dependencies
+###################
+LIN_DRIVERS ??= " sllin"
+# These boards use different kernels - needs to be checked
+LIN_DRIVERS_dra7xx-evm ?= ""
+LIN_DRIVERS_dragonboard-410c ?= ""
+
+# UNICENS service
+UNICENS ?= " \
unicens-config \
agl-service-unicens \
"
-# @Chris: This needs to be checked!
-MOST_HVAC_dra7xx-evm = ""
-MOST_HVAC_dragonboard-410c = ""
AGL_APPS = " \
dashboard \
@@ -82,7 +89,9 @@ RDEPENDS_${PN}_append = " \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
linux-firmware-ralink \
- ${MOST_HVAC} \
+ ${UNICENS} \
+ ${MOST_DRIVERS} \
+ ${LIN_DRIVERS} \
${AGL_APPS} \
${AGL_APIS} \
${QTAGLEXTRAS} \