summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-08-30 14:18:23 -0400
committerScott Murray <scott.murray@konsulko.com>2019-09-02 11:07:41 -0400
commit3cc80df78623edf03f7b203ff47828f77e5cf4cd (patch)
treed13ae7e0170526492185f30de672181c2c819baf /recipes-platform
parent63d61630c728adaa3465c8f319e586a765d9804b (diff)
Update demo features for switch to ondemandnavi
The ondemandnavi navigation application does not work with the mapviewer cluster demo application, so update the logic to handle the agl-cluster-demo-support feature in packagegroup-agl-demo-platform to not pull it in when using ondemandnavi as the virtual/navigation provider. Since the plan is to replace mapviewer with an equivalent QtLocation based map streamer for the cluster demo, the mapviewer-demo recipe has also been replaced with a more generically named cluster-demo-network-config recipe. Additionally, the agl-demo-preload feature logic has been tweaked to not pull in the map package for the old navigation application when using ondemandnavi. Bug-AGL: SPEC-2576 Change-Id: I57b45ab152f9fab6cee97d570be1949136cd39eb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--[-rwxr-xr-x]recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index b6bda83b..e15134c2 100755..100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -60,12 +60,17 @@ AGL_APIS = " \
QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
-# mapviewer and mapviewer-demo are required for AGL cluster demo
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
-
-# Preload navigation maps and poi API key for demo if requested
+# Cluster demo support.
+# ATM mapviewer is required for navigation map viewing when doing cluster
+# demos with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
+
+# Preload poi API key for demo if requested, and potentially maps for older
+# navigation application if it is configured.
DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
+DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
# Hook for demo platform configuration
# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
@@ -82,7 +87,7 @@ RDEPENDS_${PN}_append = " \
${AGL_APPS} \
${AGL_APIS} \
${QTAGLEXTRAS} \
- ${MAPVIEWER} \
+ ${CLUSTER_SUPPORT} \
${DEMO_PRELOAD} \
${DEMO_PLATFORM_CONF} \
"