summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-27 12:30:46 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-29 10:27:17 +0000
commit6ed7c8437f9fb979dca29bd8643fc19e8470e041 (patch)
tree166003efbe279e819e1eb28f88dfbe3931718b78 /recipes-platform
parent19872cdb6a805eebfe286b6576f0b6a3ec215bd1 (diff)
Add preconfigured demo control panel images
Changes: - Add kuksa-dbc-feeder configuration package for the gateway flavor of the control panel image. - Split out the agl-demo-control-panel configuration into a separate package, and add alternative versions for running against the regular and gateway versions of the full demo. - Add -preconfigured and -preconfigured-gateway flavors of the agl-ivi-demo-control-panel image that add the appropriate tweaks to support the full demo setups. Bug-AGL: SPEC-5107, SPEC-5138 Change-Id: I290d08c0f7234f951b822b161bce8166fb62d346 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29943 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-ivi-demo-control-panel-preconfigured-gateway.bb11
-rw-r--r--recipes-platform/images/agl-ivi-demo-control-panel-preconfigured.bb7
-rw-r--r--recipes-platform/images/agl-ivi-demo-control-panel.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured-gateway.bb b/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured-gateway.bb
new file mode 100644
index 00000000..19575a8e
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured-gateway.bb
@@ -0,0 +1,11 @@
+require agl-ivi-demo-control-panel.bb
+
+SUMMARY = "AGL gateway demo control panel image"
+
+IMAGE_FEATURES += "kuksa-val-databroker"
+
+IMAGE_INSTALL += " \
+ agl-demo-control-panel-conf-gateway-demo \
+ vss-agl-control-panel \
+ kuksa-dbc-feeder-conf-control-panel \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured.bb b/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured.bb
new file mode 100644
index 00000000..1107b9c7
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-control-panel-preconfigured.bb
@@ -0,0 +1,7 @@
+require agl-ivi-demo-control-panel.bb
+
+SUMMARY = "AGL full demo control panel image"
+
+IMAGE_INSTALL += " \
+ agl-demo-control-panel-conf-demo \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-control-panel.bb b/recipes-platform/images/agl-ivi-demo-control-panel.bb
index 21785cae..7524ada5 100644
--- a/recipes-platform/images/agl-ivi-demo-control-panel.bb
+++ b/recipes-platform/images/agl-ivi-demo-control-panel.bb
@@ -2,6 +2,8 @@ require recipes-platform/images/agl-image-weston.bb
SUMMARY = "AGL demo control panel image"
+require agl-demo-features.inc
+
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
# NOTE: The client key and certificate in kuksa-certificates-agl-client