summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-12-21 10:00:54 -0500
committerScott Murray <scott.murray@konsulko.com>2021-12-21 10:17:36 -0500
commite3e399730736deb17b4fa36f2fedda39cf510243 (patch)
treed023142cca0a1d2aa34ade9c2e072d65e94ee205 /recipes-platform
parent1c8e6f77e6c55fbc73779e5ce18926aba176d2fc (diff)
Add updated demo applications back
Add updated recipes for the dashboard, hvac, ondemandnavi, and settings Qt demo applications, as well as for the libqtappfw library they use and its new dependency bluez-glib. The applications are added back to the packagegroup-agl-demo-platform as they were before. Also remove a couple of leftover things in the packagegroup recipe to clean up. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0ea36c809d9126284c597cd79eded8ab031205da
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 0276a708..6ce928fe 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -23,30 +23,27 @@ RDEPENDS:${PN} += "\
packagegroup-agl-demo \
"
+AGL_APPS = " \
+ dashboard \
+ hvac \
+ ondemandnavi \
+ settings \
+ "
-DEMO_UNIT_CONF ?= ""
# Hook for demo platform configuration
# ATM used for:
# 1) Adding udev configuration and scripts for supporting USB attached
# I2C devices for RTC and HVAC LED support.
-DEMO_UNIT_CONF += " demo-i2c-udev-conf "
+DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
# Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
RDEPENDS:${PN}:append = " \
launcher \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+ ${AGL_APPS} \
${DEMO_PRELOAD} \
"
-
-# NOTE: Currently no coverage versions for the application widgets,
-# they should be added here when available.
-# Also, the navigation and mixer debug widgets are currently
-# specified explicitly, as there's no simple way to derive their
-# names from the virtual/ RPROVIDES at present.
-RDEPENDS:${PN}-devel = " \
- packagegroup-hmi-framework-devel \
- "