summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-21 18:32:35 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-23 15:04:44 +0000
commitc75d04a5ee7c32e0405ecb6de0c20d7f48b7f1e9 (patch)
tree542d83be7c0e82f01111d9a64979e6f1e1e7629a /recipes-platform
parent7dcdecf5b01f48a8fbd16fe05ebede08bf5b76a8 (diff)
KVM demo updates
Changes: - Fix native-shell-client systemd unit to work with the changes made for SPEC-4714 (separate agl-compositor systemd unit, running as agl-driver). - Update agl-qemu-runner.sh for the SPEC-4714 changes. - Tweak cluster guest configuration to use just 2 cores and 1 GB of memory to free up resources for the host. - Add inverted psplash configuration that is pulled in for the KVM demo image when building with agl-demo-preload. This matches the inverted screen in the demo hardware. Bug-AGL: SPEC-4974 Change-Id: Ie57a3550c8c8b12fd64ee14a9f1fbf4a4c40da32 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29460 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account (cherry picked from commit 6dc0e32fbda2c122a2b59630d774dc4ef1a49619) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29363
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index fc3cc51f..a6514c75 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -20,8 +20,10 @@ IMAGE_KUKSA_PACKAGES = " \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'kuksa-databroker-cli' , '', d)} \
"
+
# generic
IMAGE_INSTALL += "\
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
\
packagegroup-agl-networking \