summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorAakash Solanki <tech2aks@gmail.com>2022-08-06 13:49:55 +0200
committerAakash Solanki <tech2aks@gmail.com>2022-08-06 14:28:10 +0200
commit85d834afe1cdc9c25e3d94daefc8d515b7d0c361 (patch)
tree3f9bb3af126091f88b7b9fb5dff11d983f53144a /recipes-platform
parent1358fce0ca46b764e12c6bee79e8f5239baa60f9 (diff)
Add a new image for Flutter instrument cluster app
- Add a new image: agl-cluster-demo-platform-flutter - Add recipe for instrument cluster app - Pin instrument cluster app with kuksa-val-server. Bug-AGL: SPEC-4508 Change-Id: I04dc536e5700fb6b92e8c9a672ebb107c73e6724 Signed-off-by: aakashs45 <tech2aks@gmail.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
new file mode 100644
index 00000000..40aa6e86
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Baseline Flutter Image for Release"
+
+LICENSE = "MIT"
+
+
+require recipes-platform/images/agl-image-weston.inc
+
+# generic
+IMAGE_INSTALL:append = "\
+ agl-compositor \
+ agl-compositor-init \
+ packagegroup-agl-profile-graphical \
+ packagegroup-agl-ivi-services \
+ "
+
+# flutter
+IMAGE_INSTALL:append = "\
+ weston-ini-conf-landscape \
+ \
+ flutter-cluster-dashboard-runtimerelease \
+ flutter-cluster-dashboard-runtimerelease-init \
+ flutter-auto-runtimerelease \
+ "
+
+CLANGSDK = "1"