aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/packagegroups
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-09-24 23:02:42 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-09-24 23:08:26 +0200
commitd29502281765bcf73a6d422e67587a8d3ee0b2dd (patch)
treecaa6b7f7c4c23820a2de809d13a7804368b24251 /recipes-qt/packagegroups
parent63d7f3539b8fc188d1c95ff2cc5095efdfdc8f93 (diff)
Qt5 now avairable in agl-demo-platfrom.
v3: (Jan-Simon Möller) - Added meta-ruby to bblayers template file v2: (Jan-Simon Möller) - Added meta-qt5 to bblayers template file - Removed unused patches (rpm specfile) v1: Support Qt5 for AGL Demo applications as UI Framework Qt5 now avairable in agl-demo-platfrom. This is a initial commit to support Qt5 for GUI Framework of AGL Distro. For now, these components are included into agl-demo-platform as default, Additional meta data for Qt5 (recipes-qt/qt5/*) is from: URL: git://git.projects.genivi.org/meta-genivi-demo commit: dc64c97667bac6046c878c689af579089f30641e To build and install Qt5 examples, need to setup local.conf properly, see README.md for more detail. Change-Id: I6c298d4f650a5ac8ee8f12acd1ee28df15e7dfad Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-qt/packagegroups')
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb40
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb33
2 files changed, 73 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
new file mode 100644
index 00000000..4efba959
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
+DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-native-qt5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ qtbase \
+ qtbase-dev \
+ qtbase-fonts \
+ qtbase-fonts-pfa \
+ qtbase-fonts-pfb \
+ qtbase-fonts-qpf \
+ qtbase-fonts-ttf-dejavu \
+ qtbase-fonts-ttf-vera \
+ qtbase-plugins \
+ qtbase-staticdev \
+ qtbase-tools \
+ qtdeclarative \
+ qtdeclarative-plugins \
+ qtdeclarative-qmlplugins \
+ qtdeclarative-tools \
+ qtquick1 \
+ qtquick1-plugins \
+ qtquick1-tools \
+ qtwayland \
+ qtwayland-examples \
+ qtwayland-plugins \
+ qtwayland-tools \
+ qtwebkit \
+ qtwebkit-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
+ "
diff --git a/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb b/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb
new file mode 100644
index 00000000..7c195459
--- /dev/null
+++ b/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb
@@ -0,0 +1,33 @@
+SUMMARY = "The examples to test Qt5 on AGL Demo Platform"
+DESCRIPTION = "A set of packages which contains Qt5 examples"
+
+LICENSE = "MIT"
+
+PR="r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-demo-qt-examples \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ qt3d-examples \
+ qtbase-examples \
+ qtconnectivity-examples \
+ qtdeclarative-examples \
+ qtlocation-examples \
+ qtmultimedia-examples \
+ qtquick1-examples \
+ qtscript-examples \
+ qtsensors-examples \
+ qtsvg-examples \
+ qtsystems-examples \
+ qttools-examples \
+ qtwayland-examples \
+ qtxmlpatterns-examples \
+ qtquick1-examples \
+ qtwebkit-examples-examples \
+ "