summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2015-12-08 02:08:46 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-12-08 02:08:46 +0000
commit084af25d6fbe3f4e02c4c93bea98d89dbd113ed1 (patch)
treea1045c8c8faad7d90246cdf8b1768f8cb8f02990 /recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
parent38a51bc5152e2a95fa6d89d5828de643e1592559 (diff)
Update AM/FM radio QML plugin to version 0.2
This commit upgrades qml-radio-plugin to version 0.2, which : - implements PulseAudio support (will work automatically if we enable it inside AGL) ; - fixes QML properties and types as requested in [*] ; - fixes sound stuttering issues. It also puts the non-mandatory QML sample in a separate "examples" package, thus avoiding building qtquickcontrols if we do not need it. [*] : http://lists.linuxfoundation.org/pipermail/ automotive-discussions/2015-December/001244.html Change-Id: I2b173d8bb1c4055b2c7ac0c4691d802c2eb5f61f Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb')
-rw-r--r--recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
deleted file mode 100644
index 60360aa06..000000000
--- a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "AM/FM Radio QML plugin (for RTL2832U hardware)"
-DESCRIPTION = "This provides a simple QML plugin able to detect and use radio hardware, most notable RTL2832U chipsets (although it can easily be extended). Among other things, it provides generic APIs to display status, switch between AM/FM mode, choose frequency, mute sound..."
-HOMEPAGE = "https://github.com/iotbzh/qml_radio_plugin"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://qml_radio.cpp;endline=16;md5=10a65c128e3a6cff2a61bb38556ceb04"
-
-DEPENDS = "qtbase-native qtdeclarative rtl-sdr alsa-lib"
-RDEPENDS_${PN} = "qtdeclarative-tools qtquickcontrols-qmlplugins"
-
-SRC_URI = "git://github.com/iotbzh/qml_radio_plugin"
-SRCREV = "0032dc92d1a208219a0f782b68aef7f4cbcc0028"
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
-
-QML_LIBDIR = "${libdir}/qt5/qml"
-
-do_install_append() {
- # Remove .la files for loadable modules
- rm -f ${D}/${QML_LIBDIR}/radio/*.la
- # Install QML example
- install -d ${D}/${datadir}/qt5/examples/radio
- install -m 0644 ${S}/radio.qml ${D}/${datadir}/qt5/examples/radio
-}
-
-FILES_${PN} += "${QML_LIBDIR}/radio/*.so ${QML_LIBDIR}/radio/qmldir ${datadir}"
-FILES_${PN}-dbg += "${QML_LIBDIR}/radio/.debug"