summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt-qrcode/qt-qrcode_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-29 18:51:16 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-30 14:59:45 +0000
commit80d8e80fb02a5667c279ef492b778169fd9c5066 (patch)
treecbe5d9cf0c1771c4b55c2c1647aad986ee650324 /recipes-qt/qt-qrcode/qt-qrcode_git.bb
parent0c284fb6273dc039c1573e2f6681e9c56708d0f1 (diff)
Add qt-qrcode recipe for use in settings app
Add a recipe for the qt-qrcode libqrencode wrapper library to allow using it to display QR codes in the settings app, and update the settings app dependencies to add it as a dependency. As cleanup, the qtwebsockets dependency has been dropped from settings since it no longer requires it. Bug-AGL: SPEC-2981 Change-Id: Ia0d40ea1151765fa967457bf2ab6624dc7bc259d Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-qt/qt-qrcode/qt-qrcode_git.bb')
-rw-r--r--recipes-qt/qt-qrcode/qt-qrcode_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-qt/qt-qrcode/qt-qrcode_git.bb b/recipes-qt/qt-qrcode/qt-qrcode_git.bb
new file mode 100644
index 00000000..8b3ff79a
--- /dev/null
+++ b/recipes-qt/qt-qrcode/qt-qrcode_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Qt QR code library"
+DESCRIPTION = "Qt/C++ library for encoding and visualization of data in a \
+QR Code symbol. This library consists of a Qt wrapper for libqrencode, and \
+Qt components that are able to visualize the result."
+LICENSE = "LGPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94a3f3bdf61243b5e5cf569fbfbbea52"
+
+DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtsvg qrencode"
+
+SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https \
+ file://0001-rework-library-build.patch \
+"
+SRCREV = "2d57d9c6e2341689d10f9360a16a08831a4a820b"
+
+PV = "git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+inherit qmake5