summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-qt
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb4
-rw-r--r--recipes-qt/qt/qtbase_agldemo.inc2
-rw-r--r--recipes-qt/qt/qtlocation_agldemo.inc2
-rw-r--r--recipes-qt/qt/qtmultimedia_agldemo.inc6
-rw-r--r--recipes-qt/qt/qtsystems_agldemo.inc4
-rw-r--r--recipes-qt/qt/qtwayland-config_1.0.0.bb2
-rw-r--r--recipes-qt/qt/qtwayland_agldemo.inc4
7 files changed, 12 insertions, 12 deletions
diff --git a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb b/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
index 49111b6e8..131210897 100644
--- a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
+++ b/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
@@ -29,7 +29,7 @@ KERNEL=="rgnmm", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack
EOF
}
-do_install_append_imx() {
+do_install:append:imx() {
install -d ${D}${sysconfdir}/udev/rules.d
cat >>${D}${sysconfdir}/udev/rules.d/zz-dri.rules <<'EOF'
SUBSYSTEM=="gpu_class", MODE="0660", GROUP="${WESTONGROUP}", SECLABEL{smack}="*"
@@ -37,4 +37,4 @@ EOF
}
-RCONFLICTS_${PN} = "weston-init"
+RCONFLICTS:${PN} = "weston-init"
diff --git a/recipes-qt/qt/qtbase_agldemo.inc b/recipes-qt/qt/qtbase_agldemo.inc
index 7f48b4571..5e6477985 100644
--- a/recipes-qt/qt/qtbase_agldemo.inc
+++ b/recipes-qt/qt/qtbase_agldemo.inc
@@ -1 +1 @@
-PACKAGECONFIG_append = " icu fontconfig sql-sqlite"
+PACKAGECONFIG:append = " icu fontconfig sql-sqlite"
diff --git a/recipes-qt/qt/qtlocation_agldemo.inc b/recipes-qt/qt/qtlocation_agldemo.inc
index 7d112d03d..60867aef0 100644
--- a/recipes-qt/qt/qtlocation_agldemo.inc
+++ b/recipes-qt/qt/qtlocation_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/qtlocation:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/qtlocation:"
SRC_URI += "\
file://0001-mapbox-update-API-url-to-match-new-schema.patch \
diff --git a/recipes-qt/qt/qtmultimedia_agldemo.inc b/recipes-qt/qt/qtmultimedia_agldemo.inc
index a8ef5afa1..0734a3664 100644
--- a/recipes-qt/qt/qtmultimedia_agldemo.inc
+++ b/recipes-qt/qt/qtmultimedia_agldemo.inc
@@ -1,7 +1,7 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/qtmultimedia"
+FILESEXTRAPATHS:append := ":${THISDIR}/qtmultimedia"
-PACKAGECONFIG_append = " gstreamer"
+PACKAGECONFIG:append = " gstreamer"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0001-metadata-image-support-with-the-data-URL-scheme-for-.patch \
"
diff --git a/recipes-qt/qt/qtsystems_agldemo.inc b/recipes-qt/qt/qtsystems_agldemo.inc
index 550c58d05..9cd33c8a1 100644
--- a/recipes-qt/qt/qtsystems_agldemo.inc
+++ b/recipes-qt/qt/qtsystems_agldemo.inc
@@ -1,3 +1,3 @@
-DEPENDS_remove = "bluez4"
+DEPENDS:remove = "bluez4"
# currently Qt5 does not support bluez5 "Nothing PROVIDES 'gconfbluez5'"
-#DEPENDS_append = "bluez5"
+#DEPENDS:append = "bluez5"
diff --git a/recipes-qt/qt/qtwayland-config_1.0.0.bb b/recipes-qt/qt/qtwayland-config_1.0.0.bb
index ae7c956d4..7c1e99bfa 100644
--- a/recipes-qt/qt/qtwayland-config_1.0.0.bb
+++ b/recipes-qt/qt/qtwayland-config_1.0.0.bb
@@ -18,4 +18,4 @@ do_install () {
sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
}
-RPROVIDES_${PN} += "virtual/qtwayland-config"
+RPROVIDES:${PN} += "virtual/qtwayland-config"
diff --git a/recipes-qt/qt/qtwayland_agldemo.inc b/recipes-qt/qt/qtwayland_agldemo.inc
index 61d0393a5..b24c7b7b1 100644
--- a/recipes-qt/qt/qtwayland_agldemo.inc
+++ b/recipes-qt/qt/qtwayland_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/qtwayland"
+FILESEXTRAPATHS:append := ":${THISDIR}/qtwayland"
# QT_MODULE_BRANCH = "5.4"
@@ -12,7 +12,7 @@ FILESEXTRAPATHS_append := ":${THISDIR}/qtwayland"
# file://0002-qwaylandwindow-add-support-for-IVI-Surface-ID-proper.patch \
#
-SRC_URI_append = "\
+SRC_URI:append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
file://0001-client-qwaylandintegration-Do-not-attempt-to-use-the.patch \
"