summaryrefslogtreecommitdiffstats
path: root/recipes-support/lin-config/files
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-06 16:14:57 -0500
committerScott Murray <scott.murray@konsulko.com>2019-11-06 16:20:50 -0500
commit9720369548deb31910c6addabad74886653444bc (patch)
tree48040f5ac87f39020dbe7bdaad041bce28660331 /recipes-support/lin-config/files
parentd367bf23b04810d53351c63e6505376eaacc32ae (diff)
Update LIN demo to use lin-config
Changes include: - Add patch to fix lin-config recipe build QA error. - Tweak lin-config recipe to install lin_config as executable. - Rework sllin-demo systemd unit and start_lin_demo.sh script to use lin_config with an appropriate configuration file that enables polling of the steering wheel adapter instead of just using ldattach. Bug-AGL: SPEC-2918 Change-Id: I3258b7e34cecbbb1cfb93ea6f63a44f0bbb2c06f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-support/lin-config/files')
-rw-r--r--recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
new file mode 100644
index 00000000..26364455
--- /dev/null
+++ b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
@@ -0,0 +1,20 @@
+Use LDFLAGS when linking
+
+Use LDFLAGS when linking the output binary to quiet QA warnings due to
+missing link flags.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+--- a/Makefile 2019-11-05 11:08:11.060565285 +0000
++++ b/Makefile 2019-11-05 11:09:38.663570084 +0000
+@@ -6,7 +6,7 @@
+ objects = linc_parse_xml.o pcl_config.o sllin_config.o lin_config.o
+
+ lin_config: $(objects)
+- $(CC) $(objects) $(LIBS) -o lin_config
++ $(CC) $(LDFLAGS) $(objects) $(LIBS) -o lin_config
+
+ %.o : %.c %.h
+ $(CC) $(CFLAGS) $(LIBS) -c $< -o $@