summaryrefslogtreecommitdiffstats
path: root/recipes-support/lin-config/lin-config_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-06 16:14:57 -0500
committerScott Murray <scott.murray@konsulko.com>2019-11-06 16:20:50 -0500
commit9720369548deb31910c6addabad74886653444bc (patch)
tree48040f5ac87f39020dbe7bdaad041bce28660331 /recipes-support/lin-config/lin-config_git.bb
parentd367bf23b04810d53351c63e6505376eaacc32ae (diff)
Update LIN demo to use lin-config
Changes include: - Add patch to fix lin-config recipe build QA error. - Tweak lin-config recipe to install lin_config as executable. - Rework sllin-demo systemd unit and start_lin_demo.sh script to use lin_config with an appropriate configuration file that enables polling of the steering wheel adapter instead of just using ldattach. Bug-AGL: SPEC-2918 Change-Id: I3258b7e34cecbbb1cfb93ea6f63a44f0bbb2c06f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-support/lin-config/lin-config_git.bb')
-rw-r--r--recipes-support/lin-config/lin-config_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
index 6c8db847..e83f7160 100644
--- a/recipes-support/lin-config/lin-config_git.bb
+++ b/recipes-support/lin-config/lin-config_git.bb
@@ -2,7 +2,6 @@ DESCRIPTION = "lin-config tool for the sllin driver module"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
DEPENDS += "libnl libxml2"
SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
@@ -11,17 +10,16 @@ S = "${WORKDIR}/git/lin_config/src"
SRC_URI_append = " \
file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+ file://0002-Change-Makefile-to-use-LDFLAGS.patch \
"
inherit pkgconfig
PV = "0.1+git${SRCPV}"
-
do_configure[noexec] = "1"
do_install_append() {
-
install -d ${D}/${bindir}
- install -m 644 ${S}/lin_config ${D}/${bindir}
-} \ No newline at end of file
+ install -m 755 ${S}/lin_config ${D}/${bindir}
+}