summaryrefslogtreecommitdiffstats
path: root/recipes-support/lin-config/lin-config_git.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-10-21 11:33:54 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-10-23 07:10:56 +0000
commit8a55ca4d1658c18f8b750c0a2d9e07a65099e31d (patch)
tree56ed8b4399f01f0805a4d577aa5253701982d28e /recipes-support/lin-config/lin-config_git.bb
parent7d4f347cfeef55b23b41c1dcd4b29db7ef2d24e8 (diff)
Add lin-config tool to facilitate polling
This tool allows to setup the BCM in the linux kernel to poll the lin bus. This is needed to query the steering wheel. Bug-AGL: SPEC-2918 . Change-Id: I4887c0d179b4e93aa7bae6406057a8bd8ba79999 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-support/lin-config/lin-config_git.bb')
-rw-r--r--recipes-support/lin-config/lin-config_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
new file mode 100644
index 00000000..6c8db847
--- /dev/null
+++ b/recipes-support/lin-config/lin-config_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "lin-config tool for the sllin driver module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+
+DEPENDS += "libnl libxml2"
+
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
+S = "${WORKDIR}/git/lin_config/src"
+
+SRC_URI_append = " \
+ file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+ "
+
+inherit pkgconfig
+
+PV = "0.1+git${SRCPV}"
+
+
+do_configure[noexec] = "1"
+
+do_install_append() {
+
+ install -d ${D}/${bindir}
+ install -m 644 ${S}/lin_config ${D}/${bindir}
+} \ No newline at end of file