summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-06 16:14:57 -0500
committerScott Murray <scott.murray@konsulko.com>2019-11-06 21:08:14 +0000
commit3fe7f283824a7afb6ffe22a904d57b28a9b69a72 (patch)
tree4d556ba9486bc6ca7af6ed0169ea2ab402075093 /recipes-support
parentc4f32fa3c22b15a513c5ba0907b1927f6db53a61 (diff)
Update LIN demo to use lin-config
Changes include: - Add patch to fix lin-config recipe build QA error. - Tweak lin-config recipe to install lin_config as executable. - Rework sllin-demo systemd unit and start_lin_demo.sh script to use lin_config with an appropriate configuration file that enables polling of the steering wheel adapter instead of just using ldattach. Bug-AGL: SPEC-2918 Change-Id: I3258b7e34cecbbb1cfb93ea6f63a44f0bbb2c06f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch20
-rw-r--r--recipes-support/lin-config/lin-config_git.bb8
2 files changed, 23 insertions, 5 deletions
diff --git a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
new file mode 100644
index 00000000..26364455
--- /dev/null
+++ b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
@@ -0,0 +1,20 @@
+Use LDFLAGS when linking
+
+Use LDFLAGS when linking the output binary to quiet QA warnings due to
+missing link flags.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+--- a/Makefile 2019-11-05 11:08:11.060565285 +0000
++++ b/Makefile 2019-11-05 11:09:38.663570084 +0000
+@@ -6,7 +6,7 @@
+ objects = linc_parse_xml.o pcl_config.o sllin_config.o lin_config.o
+
+ lin_config: $(objects)
+- $(CC) $(objects) $(LIBS) -o lin_config
++ $(CC) $(LDFLAGS) $(objects) $(LIBS) -o lin_config
+
+ %.o : %.c %.h
+ $(CC) $(CFLAGS) $(LIBS) -c $< -o $@
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
index 6c8db847..e83f7160 100644
--- a/recipes-support/lin-config/lin-config_git.bb
+++ b/recipes-support/lin-config/lin-config_git.bb
@@ -2,7 +2,6 @@ DESCRIPTION = "lin-config tool for the sllin driver module"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
DEPENDS += "libnl libxml2"
SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
@@ -11,17 +10,16 @@ S = "${WORKDIR}/git/lin_config/src"
SRC_URI_append = " \
file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+ file://0002-Change-Makefile-to-use-LDFLAGS.patch \
"
inherit pkgconfig
PV = "0.1+git${SRCPV}"
-
do_configure[noexec] = "1"
do_install_append() {
-
install -d ${D}/${bindir}
- install -m 644 ${S}/lin_config ${D}/${bindir}
-} \ No newline at end of file
+ install -m 755 ${S}/lin_config ${D}/${bindir}
+}