summaryrefslogtreecommitdiffstats
path: root/recipes-test
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-test
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-test')
-rw-r--r--recipes-test/gcovr-wrapper/gcovr-wrapper_1.0.bb2
-rw-r--r--recipes-test/gcovr/gcovr_git.bb2
-rw-r--r--recipes-test/pyagl/pyagl_git.bb4
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-test/gcovr-wrapper/gcovr-wrapper_1.0.bb b/recipes-test/gcovr-wrapper/gcovr-wrapper_1.0.bb
index 2ff39b211..8cb228d50 100644
--- a/recipes-test/gcovr-wrapper/gcovr-wrapper_1.0.bb
+++ b/recipes-test/gcovr-wrapper/gcovr-wrapper_1.0.bb
@@ -14,4 +14,4 @@ do_install() {
install -D -m 0755 ${WORKDIR}/gcovr-wrapper ${D}${bindir}/gcovr-wrapper
}
-RDEPENDS_${PN} = "bash gcovr"
+RDEPENDS:${PN} = "bash gcovr"
diff --git a/recipes-test/gcovr/gcovr_git.bb b/recipes-test/gcovr/gcovr_git.bb
index 6da04cc53..d302c0f63 100644
--- a/recipes-test/gcovr/gcovr_git.bb
+++ b/recipes-test/gcovr/gcovr_git.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/git"
inherit setuptools3
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-compression \
python3-core \
python3-crypt \
diff --git a/recipes-test/pyagl/pyagl_git.bb b/recipes-test/pyagl/pyagl_git.bb
index a2dc273fb..ee01ce52f 100644
--- a/recipes-test/pyagl/pyagl_git.bb
+++ b/recipes-test/pyagl/pyagl_git.bb
@@ -11,11 +11,11 @@ S = "${WORKDIR}/git"
inherit setuptools3
-do_install_append() {
+do_install:append() {
install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
}
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-asyncio \
python3-asyncssh \
python3-core \