summaryrefslogtreecommitdiffstats
path: root/recipes-wam/chromium/chromium-browser-service.bb
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2021-04-07 17:01:14 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-05-12 08:54:16 +0000
commite96145a39d9138029306608398ba13644f6f0cf6 (patch)
treefdc9d1370f4947824d78dfba15c27caddf326646 /recipes-wam/chromium/chromium-browser-service.bb
parent4c1450800aadb7dcd26819fcc14586bd572abc56 (diff)
Restore chromium target and browser servicelamprey_11.91.0lamprey/11.91.011.91.0
- Merged chromium changes to fix build after bumping to chromium 84 - Fixed chromium install on current recipe - Restored the chromium browser service Bug-AGL: SPEC-3830 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: I5cde7972021a4200581c2e161f848bcf7d8d0458
Diffstat (limited to 'recipes-wam/chromium/chromium-browser-service.bb')
-rw-r--r--recipes-wam/chromium/chromium-browser-service.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
new file mode 100644
index 00000000..58177ce9
--- /dev/null
+++ b/recipes-wam/chromium/chromium-browser-service.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Chromium browser widget"
+DESCRIPTION = "Wgt packaging for running chromium installed browser"
+HOMEPAGE = "https://webosose.org"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/chromium;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+#build-time dependencies
+DEPENDS += "af-binder af-main-native chromium84"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "chromium84-browser"