summaryrefslogtreecommitdiffstats
path: root/recipes-wam/chromium/chromium_git.bb
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-02-01 17:04:32 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-02-15 22:12:19 +0000
commitdee3a47a4d12561f82747f1907081235abf691f8 (patch)
tree0149a3a5587924af9e12b15d9e634fcb700c7df4 /recipes-wam/chromium/chromium_git.bb
parent1e713e0e0823965615caa8956d490018f8efea74 (diff)
chromium, wam: update to chromium87 tree.
Update to chromium87 tree, and wam adapted to chromium87. This does not include yet the webOS OSE QtLess version, but the submission right before QtLess work. This is because in webOS OSE current chromium87 release, the only work after the submission we are using is QtLess, without adding any new functionality. Renamed the recipe and package name to be "chromium" instead of "chromium84" or "chromium87". Now we use PV to state the version of the upstream Chromium. The Chromium87 tree history has been heavily simplified to make it easier to rebase in next upgrades. Bug-AGL: SPEC-4142, SPEC-4225, SPEC-4227, SPEC-4228 Change-Id: I6caed396f758dd80291803266f6a59f1fec406c4 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-wam/chromium/chromium_git.bb')
-rw-r--r--recipes-wam/chromium/chromium_git.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes-wam/chromium/chromium_git.bb b/recipes-wam/chromium/chromium_git.bb
new file mode 100644
index 00000000..e58932c1
--- /dev/null
+++ b/recipes-wam/chromium/chromium_git.bb
@@ -0,0 +1,83 @@
+require chromium.inc
+
+SRC_URI = "\
+ git://github.com/igalia/chromium87;branch=@10.agl.marlin;protocol=https;rev=${SRCREV_chromium87};name=chromium87 \
+ git://github.com/webosose/chromium-v8;branch=@chromium87;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
+"
+
+# Needed by catapult
+DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
+
+SRCREV_chromium87 = "7412ccde56b8054af89d6f515bc7c852287fc3b2"
+SRCREV_v8 = "935065d097cce0090bc858746e6aee0919b222de"
+
+CHROMIUM_VERSION = "87.0.4280.88"
+PV_BRANCH_SUFFIX = "ose10.agl.marlin"
+
+PV = "${CHROMIUM_VERSION}.${PV_BRANCH_SUFFIX}+git"
+
+BROWSER_APPLICATION = "chromium-browser"
+BROWSER_APPLICATION_DIR = "/opt/chromium"
+MKSNAPSHOT_PATH = "v8_snapshot/"
+
+GN_ARGS += "use_gtk=false"
+
+# Disable closure compile
+# Else we need HOSTTOOLS += "java"
+GN_ARGS += " \
+ enable_mojom_closure_compile=false\
+ enable_js_type_check=false\
+"
+
+# When using meta-clang, one can switch to using the lld linker
+# by using the ld-is-lld distro feature otherwise use gold linker
+GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'use_lld=false use_gold=true', 'use_lld=false use_gold=false', d), d)}"
+
+# Toolchains we will use for the build. We need to point to the toolchain file
+# we've created, set the right target architecture and make sure we are not
+# using Chromium's toolchain (bundled clang, bundled binutils etc).
+GN_ARGS += "\
+ host_toolchain=\"//build/toolchain/cros:host\" \
+ cros_host_is_clang=false \
+ use_custom_libcxx_for_host=false \
+ cros_host_ar=\"${BUILD_AR}\" \
+ cros_host_cc=\"${BUILD_CC} ${BUILD_CFLAGS}\" \
+ cros_host_cxx=\"${BUILD_CXX} ${BUILD_CXXFLAGS}\" \
+ cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
+ custom_toolchain=\"//build/toolchain/cros:target\" \
+ is_clang=false \
+ use_custom_libcxx=false \
+ target_cpu=\"${@gn_arch_name('${TUNE_ARCH}')}\" \
+ cros_target_ar=\"${AR}\" \
+ cros_target_cc=\"${CC}\" \
+ cros_target_cxx=\"${CXX}\" \
+ cros_target_extra_ldflags=\"${LDFLAGS}\" \
+ v8_snapshot_toolchain=\"//build/toolchain/cros:v8_snapshot\" \
+ cros_v8_snapshot_is_clang=false \
+ cros_v8_snapshot_ar=\"${BUILD_AR}\" \
+ cros_v8_snapshot_cc=\"${BUILD_CC}\" \
+ cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
+ gold_path=\"\" \
+ v8_enable_embedded_builtins=false \
+ use_v8_context_snapshot=false \
+"
+
+GN_ARGS:append = " \
+ use_system_minigbm=false \
+ use_wayland_gbm=false \
+"
+
+GN_ARGS:append = " \
+ is_webos=false \
+ is_agl=true \
+"
+
+# TODO: drop this after we migrate to ubuntu 16.04 or above
+GN_ARGS += "\
+ fatal_linker_warnings=false\
+"
+
+# TODO(rzanoni) copied from original recipe to fix qemux86 build.
+# check if it can be removed in the future.
+PACKAGECONFIG:remove:qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
+#END TODO