summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2023-06-23 14:06:20 +0200
committerRoger Zanoni <rzanoni@igalia.com>2023-07-18 15:28:52 +0200
commit1ad25b9039ef910dc444e50fd43245c31d9bcae9 (patch)
treee29b75b0abcaddd0f16a7f238be7873fe0530b56 /recipes-wam/wam/wam_git.bb
parent7a7c0e1f4c62ab976dfd2a58d33ed93d62c587d3 (diff)
[wam][cef] Make it possible to use cef as a backend
This changes enables switching between the chromium and cef backends on wam by passing the agl-cef feature to the agl-setup script. Bug-AGL: SPEC-3872 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: Ib5b4b139789ec8303fef0a210a7e8f2f724d0c00
Diffstat (limited to 'recipes-wam/wam/wam_git.bb')
-rw-r--r--recipes-wam/wam/wam_git.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index 0f2087c6..570c6f8d 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -3,13 +3,16 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native grpc grpc-native"
+DEPENDS = "glib-2.0 jsoncpp boost protobuf protobuf-native grpc grpc-native"
SRC_URI = "\
git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
+ file://WebAppMgrCli \
file://WebAppMgr.service \
file://WebAppMgr.env \
+ file://WebAppMgr-cef.env \
"
+
SRCREV = "4fbd6e648913bcf0fba63e4460eb44242c11f71b"
PV = "ose58.agl"
@@ -18,12 +21,6 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig systemd
-EXTRA_OECMAKE = "\
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=${prefix} \
- -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
- -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
-
# Disable some of security flags
# Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
# Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
@@ -36,8 +33,7 @@ do_install:append() {
install -v -d ${D}${sysconfdir}/wam
install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
install -v -D -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
- install -v -D -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
- ln -snf WebAppMgr ${D}${bindir}/web-runtime
+ install -v -D -m 755 ${WORKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
}
CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
@@ -49,8 +45,14 @@ do_install:append:agl-devel() {
touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
}
-FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so"
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-cef', 'wam-cef.inc', 'wam.inc', d)}
+
+FILES:${PN} += "${sysconfdir}/init \
+ ${sysconfdir}/wam \
+ ${bindir} \
+ ${libdir}/webappmanager/plugins/*.so"
+
+RDEPENDS:${PN} += " bash"
PROVIDES += "virtual/webruntime"
RPROVIDES:${PN} += "virtual/webruntime"
-