summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-12-22 12:13:14 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-08 11:56:40 +0000
commit3ec6b8b20636befeb458c2118fc45b6aef66530f (patch)
treeef180b54aef9b9380a0f884863f9dd40d90e8aa7 /recipes-wam/wam/wam_git.bb
parent8bd9af16b19faf19c5ec86043fc734ef27688bd8 (diff)
web-runtime: Update from chromium68 to chromium79
This patch contains all the squashed changes needed to bump WAM and Chromium to M79, including all the ported changes from both upstream Chromium, webOSE and and the former chromium 68 version. It includes the needed changes on the recipes, and bumps the versions to the new commits/branches of the Chromium and Wam repositories. The split of the ongoing changes merged is available here: https://github.com/Igalia/meta-agl-html5-dev/commits/chromium79 Bug-AGL: SPEC-3576 Change-Id: Ia0de6f11001189789d4ffbf01ed81929c57bc7c5 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Diffstat (limited to 'recipes-wam/wam/wam_git.bb')
-rw-r--r--recipes-wam/wam/wam_git.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index d50a14fa..ab3a1ae0 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -5,27 +5,33 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
inherit cmake
-DEPENDS = "glib-2.0 jsoncpp boost chromium68 wayland-ivi-extension libhomescreen"
+DEPENDS = "glib-2.0 jsoncpp boost chromium79 libhomescreen"
EXTRA_OECMAKE = "\
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=${prefix} \
-DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
- -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
+ -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium79"
PR="r0"
PROVIDES += "virtual/webruntime"
RPROVIDES_${PN} += "virtual/webruntime"
+# Disable some of securit_flags
+# Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
+# Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
+lcl_maybe_fortify = ""
+SECURITY_STACK_PROTECTOR = ""
+
SRC_URI = "\
- git://github.com/igalia/${BPN}.git;branch=WIP@6.agl.compositor;protocol=https \
+ git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
file://WebAppMgr@.service \
file://WebAppMgr.env \
file://trunc-webapp-roles.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "bd650046b688eb1593ae68c16ba3912837507d08"
+SRCREV = "88e9df41cf6dfbcb5d2ea10c769a44e69171a1c3"
do_install_append() {
install -d ${D}${sysconfdir}/wam