summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-27 15:35:56 -0500
committerScott Murray <scott.murray@konsulko.com>2021-01-27 16:29:46 -0500
commit6195e3941ed7af426d5a92015c4d2658a9406895 (patch)
treef9fb4d86134eb7331fdb54090c4b5d53d1b5ca68 /recipes-wam/wam/wam_git.bb
parentf5e746f02956f8dc2cd480dd9ae9c0d7ad833b2c (diff)
wam: add user setup script/servicekoi_10.93.0koi/10.93.010.93.0
Add a per-user setup script, systemd unit to run it, and add the unit as a dependency of systemd's user-runtime-dir@.service so it will be run before the user services on each boot. This should fix the various permission issues currently being seen with WAM startup. Bug-AGL: SPEC-3781 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ie45b43a39530c23439332cdcd7f4550c9f6fc23c
Diffstat (limited to 'recipes-wam/wam/wam_git.bb')
-rw-r--r--recipes-wam/wam/wam_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index a09473ab..cf2d5fad 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -28,6 +28,8 @@ SRC_URI = "\
git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
file://WebAppMgr@.service \
file://WebAppMgr.env \
+ file://wam-user-setup.sh \
+ file://wam-user-setup@.service \
file://trunc-webapp-roles.patch \
"
S = "${WORKDIR}/git"
@@ -43,6 +45,11 @@ do_install_append() {
ln -snf WebAppMgr ${D}${bindir}/web-runtime
install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
+ install -d ${D}${libexecdir}/wam/
+ install -v -m 755 ${WORKDIR}/wam-user-setup.sh ${D}${libexecdir}/wam/wam-user-setup.sh
+ install -v -m 644 ${WORKDIR}/wam-user-setup@.service ${D}${systemd_system_unitdir}/wam-user-setup@.service
+ install -d ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
+ ln -sf ../wam-user-setup@.service ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
}
FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"