summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-27 15:35:56 -0500
committerScott Murray <scott.murray@konsulko.com>2021-01-27 16:29:46 -0500
commit6195e3941ed7af426d5a92015c4d2658a9406895 (patch)
treef9fb4d86134eb7331fdb54090c4b5d53d1b5ca68 /recipes-wam/wam/wam_git.bb
parentf5e746f02956f8dc2cd480dd9ae9c0d7ad833b2c (diff)
wam: add user setup script/servicekoi_10.93.0koi/10.93.010.93.0
Add a per-user setup script, systemd unit to run it, and add the unit as a dependency of systemd's user-runtime-dir@.service so it will be run before the user services on each boot. This should fix the various permission issues currently being seen with WAM startup. Bug-AGL: SPEC-3781 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ie45b43a39530c23439332cdcd7f4550c9f6fc23c
Diffstat (limited to 'recipes-wam/wam/wam_git.bb')
-rw-r--r--recipes-wam/wam/wam_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index a09473ab0..cf2d5fad7 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -28,6 +28,8 @@ SRC_URI = "\
git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
file://WebAppMgr@.service \
file://WebAppMgr.env \
+ file://wam-user-setup.sh \
+ file://wam-user-setup@.service \
file://trunc-webapp-roles.patch \
"
S = "${WORKDIR}/git"
@@ -43,6 +45,11 @@ do_install_append() {
ln -snf WebAppMgr ${D}${bindir}/web-runtime
install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
+ install -d ${D}${libexecdir}/wam/
+ install -v -m 755 ${WORKDIR}/wam-user-setup.sh ${D}${libexecdir}/wam/wam-user-setup.sh
+ install -v -m 644 ${WORKDIR}/wam-user-setup@.service ${D}${systemd_system_unitdir}/wam-user-setup@.service
+ install -d ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
+ ln -sf ../wam-user-setup@.service ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
}
FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
{ color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
###########################################################################
# Copyright 2017, 2018 IoT.bzh
#
# author: Fulup Ar Foll <fulup@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
#     http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.
###########################################################################

##################################################
# Control Policy Config file
##################################################
PROJECT_TARGET_ADD(4a-hal-cfg-reference)

	file(GLOB CONF_FILES "*.json")

	add_input_files("${CONF_FILES}")

	SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
	LABELS "BINDING-CONFIG"
	OUTPUT_NAME ${TARGET_NAME}
	)