summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam/wam_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:46:02 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit63e0ea358f1902b1dd9968b21b5eea649d04329e (patch)
tree4231493c300f4d9ea2c84b6e290919486bf7e0b6 /recipes-wam/wam/wam_git.bb
parent9eda76e3a9c869030ff4bcf66704207753666a6c (diff)
Move html5 demo into sublayer
The HTML5 demo needs additional fixes. Move it into a sublayer and activate with agl-demo-html5. Bug-AGL: SPEC-5188 Change-Id: I2f1a07dcfbcaf7e09d4d0d3aec1aa8f096336287 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30042 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Scott Murray <scott.murray@konsulko.com> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-wam/wam/wam_git.bb')
-rw-r--r--recipes-wam/wam/wam_git.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
deleted file mode 100644
index f76641e51..000000000
--- a/recipes-wam/wam/wam_git.bb
+++ /dev/null
@@ -1,55 +0,0 @@
-SUMMARY = "WAM"
-AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-DEPENDS = "glib-2.0 jsoncpp boost protobuf protobuf-native grpc grpc-native"
-
-SRC_URI = "\
- git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
- file://WebAppMgrCli \
- file://WebAppMgr.service \
- file://WebAppMgr.env \
- file://WebAppMgr-cef.env \
-"
-
-SRCREV = "4fbd6e648913bcf0fba63e4460eb44242c11f71b"
-
-PV = "ose58.agl"
-
-S = "${WORKDIR}/git"
-
-inherit cmake pkgconfig systemd
-
-# Disable some of security flags
-# Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
-# Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
-lcl_maybe_fortify = ""
-SECURITY_STACK_PROTECTOR = ""
-
-SYSTEMD_SERVICE:${PN} = "WebAppMgr.service"
-
-do_install:append() {
- install -v -d ${D}${sysconfdir}/wam
- install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
- install -v -D -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
- install -v -D -m 755 ${WORKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
-}
-
-CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
-
-do_install:append:agl-devel() {
- # Enable remote inspector and dev mode
- install -d ${D}${localstatedir}/agl-devel/preferences
- touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps
- touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
-}
-
-require wam-cef.inc
-
-FILES:${PN} += "${sysconfdir}/init \
- ${sysconfdir}/wam \
- ${bindir} \
- ${libdir}/webappmanager/plugins/*.so"
-
-RDEPENDS:${PN} += " bash grpc-web-proxy"