summaryrefslogtreecommitdiffstats
path: root/recipes-wam
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-wam
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-wam')
-rw-r--r--recipes-wam/chromium/chromium-browser-service.bb2
-rw-r--r--recipes-wam/chromium/chromium.inc60
-rw-r--r--recipes-wam/chromium/chromium84_git.bb8
-rw-r--r--recipes-wam/wam/wam_git.bb10
4 files changed, 40 insertions, 40 deletions
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
index 58177ce9..d9a4206d 100644
--- a/recipes-wam/chromium/chromium-browser-service.bb
+++ b/recipes-wam/chromium/chromium-browser-service.bb
@@ -16,4 +16,4 @@ DEPENDS += "af-binder af-main-native chromium84"
inherit cmake aglwgt
-RDEPENDS_${PN} += "chromium84-browser"
+RDEPENDS:${PN} += "chromium84-browser"
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
index b76ed7b6..722ba9a3 100644
--- a/recipes-wam/chromium/chromium.inc
+++ b/recipes-wam/chromium/chromium.inc
@@ -39,7 +39,7 @@ BROWSER_APPLICATION_DIR = "/opt/chromium84"
TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
-# Skip do_install_append of webos_system_bus. It is not compatible with this component.
+# Skip do_install:append of webos_system_bus. It is not compatible with this component.
WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
PACKAGECONFIG ?= "jumbo use-upstream-wayland"
@@ -118,10 +118,10 @@ GN_ARGS += "is_cfi=false"
# instead, so that if DEBUG_BUILD is not set GN will not create a huge debug
# binary anyway. Since our compiler flags are passed after GN's, -g0 does
# not cause any issues if DEBUG_BUILD is set, as -g1 will be passed later.
-DEBUG_FLAGS_remove_arm = "-g"
-DEBUG_FLAGS_append_arm = "-g1"
-DEBUG_FLAGS_remove_x86 = "-g"
-DEBUG_FLAGS_append_x86 = "-g1"
+DEBUG_FLAGS:remove:arm = "-g"
+DEBUG_FLAGS:append:arm = "-g1"
+DEBUG_FLAGS:remove:x86 = "-g"
+DEBUG_FLAGS:append:x86 = "-g1"
GN_ARGS += "symbol_level=0"
# We do not want to use Chromium's own Debian-based sysroots, it is easier to
@@ -146,17 +146,17 @@ def get_compiler_flag(params, param_name, d):
ARM_FLOAT_ABI = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'hard', 'softfp', d)}"
ARM_FPU = "${@get_compiler_flag(d.getVar('TUNE_CCARGS').split(), '-mfpu', d)}"
ARM_TUNE = "${@get_compiler_flag(d.getVar('TUNE_CCARGS').split(), '-mcpu', d)}"
-ARM_VERSION_aarch64 = "8"
-ARM_VERSION_armv7a = "7"
-ARM_VERSION_armv7ve = "7"
-ARM_VERSION_armv6 = "6"
+ARM_VERSION:aarch64 = "8"
+ARM_VERSION:armv7a = "7"
+ARM_VERSION:armv7ve = "7"
+ARM_VERSION:armv6 = "6"
# GN computes and defaults to it automatically where needed
# forcing it from cmdline breaks build on places where it ends up
# overriding what GN wants
-TUNE_CCARGS_remove = "-mthumb"
+TUNE_CCARGS:remove = "-mthumb"
-GN_ARGS_append_arm = " \
+GN_ARGS:append:arm = " \
arm_float_abi=\"${ARM_FLOAT_ABI}\" \
arm_fpu=\"${ARM_FPU}\" \
arm_tune=\"${ARM_TUNE}\" \
@@ -164,15 +164,15 @@ GN_ARGS_append_arm = " \
"
# tcmalloc's atomicops-internals-arm-v6plus.h uses the "dmb" instruction that
# is not available on (some?) ARMv6 models, which causes the build to fail.
-GN_ARGS_append_armv6 += 'use_allocator="none"'
+GN_ARGS:append:armv6 += 'use_allocator="none"'
# The WebRTC code fails to build on ARMv6 when NEON is enabled.
# https://bugs.chromium.org/p/webrtc/issues/detail?id=6574
-GN_ARGS_append_armv6 += 'arm_use_neon=false'
+GN_ARGS:append:armv6 += 'arm_use_neon=false'
# Disable glibc shims on musl
# tcmalloc does not play well with musl as of M62 (and possibly earlier).
# https://github.com/gperftools/gperftools/issues/693
-GN_ARGS_append_libc-musl = ' use_allocator_shim=false'
+GN_ARGS:append:libc-musl = ' use_allocator_shim=false'
# More options to speed up the build
GN_ARGS += "\
@@ -187,12 +187,12 @@ GN_ARGS += "\
# Doesn't build for armv[45]*
COMPATIBLE_MACHINE = "(-)"
-COMPATIBLE_MACHINE_aarch64 = "(.*)"
-COMPATIBLE_MACHINE_armv6 = "(.*)"
-COMPATIBLE_MACHINE_armv7a = "(.*)"
-COMPATIBLE_MACHINE_armv7ve = "(.*)"
-COMPATIBLE_MACHINE_x86 = "(.*)"
-COMPATIBLE_MACHINE_x86-64 = "(.*)"
+COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:armv6 = "(.*)"
+COMPATIBLE_MACHINE:armv7a = "(.*)"
+COMPATIBLE_MACHINE:armv7ve = "(.*)"
+COMPATIBLE_MACHINE:x86 = "(.*)"
+COMPATIBLE_MACHINE:x86-64 = "(.*)"
#CHROMIUM_PLUGINS_PATH = "${libdir}"
CBE_DATA_PATH = "${libdir}/cbe"
@@ -200,7 +200,7 @@ CBE_DATA_LOCALES_PATH = "${CBE_DATA_PATH}/locales"
# The text relocations are intentional -- see comments in [GF-52468]
# TODO: check if we need INSANE_SKIP on ldflags
-INSANE_SKIP_${PN} = "textrel ldflags"
+INSANE_SKIP:${PN} = "textrel ldflags"
do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
@@ -318,28 +318,28 @@ WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION = " \
${webos_sysbus_pubrolesdir}/${BROWSER_APPLICATION}.json \
"
-SYSROOT_DIRS_append = " ${bindir_cross}"
+SYSROOT_DIRS:append = " ${bindir_cross}"
-PACKAGES_prepend = " \
+PACKAGES:prepend = " \
${PN}-cross-mksnapshot \
${BROWSER_APPLICATION} \
"
-FILES_${BROWSER_APPLICATION} += " \
+FILES:${BROWSER_APPLICATION} += " \
${BROWSER_APPLICATION_DIR} \
${WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION} \
"
-RDEPENDS_${BROWSER_APPLICATION} += "${PN}"
+RDEPENDS:${BROWSER_APPLICATION} += "${PN}"
VIRTUAL-RUNTIME_gpu-libs ?= ""
-RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_gpu-libs}"
+RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_gpu-libs}"
# The text relocations are intentional -- see comments in [GF-52468]
# TODO: check if we need INSANE_SKIP on ldflags
-INSANE_SKIP_${BROWSER_APPLICATION} += "libdir ldflags textrel"
+INSANE_SKIP:${BROWSER_APPLICATION} += "libdir ldflags textrel"
-FILES_${PN} = " \
+FILES:${PN} = " \
${libdir}/*.so \
${libdir}/swiftshader/*.so \
${CBE_DATA_PATH}/* \
@@ -347,8 +347,8 @@ FILES_${PN} = " \
${WEBOS_SYSTEM_BUS_DIRS} \
"
-FILES_${PN}-dev = " \
+FILES:${PN}-dev = " \
${includedir} \
"
-FILES_${PN}-cross-mksnapshot = "${bindir_cross}/${HOST_SYS}-mksnapshot.gz"
+FILES:${PN}-cross-mksnapshot = "${bindir_cross}/${HOST_SYS}-mksnapshot.gz"
diff --git a/recipes-wam/chromium/chromium84_git.bb b/recipes-wam/chromium/chromium84_git.bb
index aef9e2e3..755c4ce9 100644
--- a/recipes-wam/chromium/chromium84_git.bb
+++ b/recipes-wam/chromium/chromium84_git.bb
@@ -18,7 +18,7 @@ BROWSER_APPLICATION = "chromium84-browser"
BROWSER_APPLICATION_DIR = "/opt/chromium84"
MKSNAPSHOT_PATH = "v8_snapshot/"
-PACKAGECONFIG_remove="jumbo"
+PACKAGECONFIG:remove="jumbo"
GN_ARGS += "use_gtk=false"
@@ -60,12 +60,12 @@ GN_ARGS += "\
use_v8_context_snapshot=false \
"
-GN_ARGS_append = " \
+GN_ARGS:append = " \
use_system_minigbm=false \
use_wayland_gbm=false \
"
-GN_ARGS_append = " \
+GN_ARGS:append = " \
is_webos=false \
is_agl=true \
"
@@ -77,5 +77,5 @@ GN_ARGS += "\
# TODO(rzanoni) copied from original recipe to fix qemux86 build.
# check if it can be removed in the future.
-PACKAGECONFIG_remove_qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
+PACKAGECONFIG:remove:qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
#END TODO
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index b9cefb89..d7245d93 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -16,7 +16,7 @@ EXTRA_OECMAKE = "\
PR="r0"
PROVIDES += "virtual/webruntime"
-RPROVIDES_${PN} += "virtual/webruntime"
+RPROVIDES:${PN} += "virtual/webruntime"
# Disable some of securit_flags
# Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
@@ -35,7 +35,7 @@ SRC_URI = "\
S = "${WORKDIR}/git"
SRCREV = "2a246d2ea79bd335b86942a5579d6de0c9ddce40"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/wam
install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
install -d ${D}${systemd_system_unitdir}
@@ -52,11 +52,11 @@ do_install_append() {
ln -sf ../wam-user-setup@.service ${D}${systemd_system_unitdir}/user-runtime-dir@.service.wants/
}
-FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
+FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
-CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"
+CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
-do_install_append_agl-devel() {
+do_install:append:agl-devel() {
# Enable remote inspector and dev mode
install -d ${D}${localstatedir}/agl-devel/preferences
touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps