summaryrefslogtreecommitdiffstats
path: root/recipes-wam
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-wam
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-wam')
-rw-r--r--recipes-wam/chromium/chromium-browser-service.bb19
-rw-r--r--recipes-wam/chromium/chromium84_git.bb2
-rw-r--r--recipes-wam/wam/wam_git.bb2
3 files changed, 2 insertions, 21 deletions
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
deleted file mode 100644
index d9a4206d..00000000
--- a/recipes-wam/chromium/chromium-browser-service.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Chromium browser widget"
-DESCRIPTION = "Wgt packaging for running chromium installed browser"
-HOMEPAGE = "https://webosose.org"
-SECTION = "apps"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/chromium;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-#build-time dependencies
-DEPENDS += "af-binder af-main-native chromium84"
-
-inherit cmake aglwgt
-
-RDEPENDS:${PN} += "chromium84-browser"
diff --git a/recipes-wam/chromium/chromium84_git.bb b/recipes-wam/chromium/chromium84_git.bb
index 3704da56..c8cb9701 100644
--- a/recipes-wam/chromium/chromium84_git.bb
+++ b/recipes-wam/chromium/chromium84_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "\
"
# Needed by catapult
-DEPENDS += "libhomescreen python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
+DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
SRCREV_chromium84 = "17ab9d58b9d5da9102b119d39cf49a002e61ea1b"
SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index 9de8573f..16820d16 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
inherit cmake
-DEPENDS = "glib-2.0 jsoncpp boost chromium84 libhomescreen protobuf protobuf-native"
+DEPENDS = "glib-2.0 jsoncpp boost chromium84 protobuf protobuf-native"
EXTRA_OECMAKE = "\
-DCMAKE_BUILD_TYPE=Release \