summaryrefslogtreecommitdiffstats
path: root/scripts/run-yocto-check-layer-all-layers.sh
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-11 16:16:15 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 09:15:45 +0000
commit1b7b7213e7a77d35b30cea990dfe03f32c0f5bea (patch)
treea29ec72ed7a9ee4b8944e5f28037f18691e8c0d7 /scripts/run-yocto-check-layer-all-layers.sh
parent50f330e3d09bffcfe070fc5ec30a6a47ceeb45df (diff)
Ensure all layers do pass yocto-check-layer and run-yocto-check-layer.sh scripts
Ensure the layers do pass again and that the scripts are up-to-date. Bug-AGL: SPEC-4680 Bug-AGL: SPEC-4685 Change-Id: I65cc70f657c9c56e396764699930cfa74d893364 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'scripts/run-yocto-check-layer-all-layers.sh')
-rwxr-xr-xscripts/run-yocto-check-layer-all-layers.sh56
1 files changed, 0 insertions, 56 deletions
diff --git a/scripts/run-yocto-check-layer-all-layers.sh b/scripts/run-yocto-check-layer-all-layers.sh
deleted file mode 100755
index 08db5d12..00000000
--- a/scripts/run-yocto-check-layer-all-layers.sh
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/bash
-set -x
-
-SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
-echo $SCRIPTPATH
-AGLROOT="$SCRIPTPATH/../.."
-POKYDIR="$AGLROOT/external/poky"
-TMPROOT=`mktemp -d`
-
-rm -rf ${TMPROOT}/testbuild-ycl || true
-mkdir -p ${TMPROOT}/testbuild-ycl
-cd ${TMPROOT}/testbuild-ycl
-
-source $POKYDIR/oe-init-build-env .
-
-cat << EOF >> conf/local.conf
-# just define defaults
-AGL_FEATURES ?= ""
-AGL_EXTRA_IMAGE_FSTYPES ?= ""
-
-# important settings imported from poky-agl.conf
-# we do not import
-DISTRO_FEATURES:append = " systemd"
-DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
-VIRTUAL-RUNTIME_init_manager = "systemd"
-#AGL_FEATURES += "aglcore agldemo"
-#DISTRO_FEATURES:append = " appfw"
-
-# workaround:
-#ERROR: Nothing RPROVIDES 'qtwebengine-qmlplugins' (but /home/dl9pf/AGL/master-newlayout/external/meta-qt5/recipes-qt/qt5/qt5-creator_git.bb RDEPENDS on or otherwise requires it)
-BBMASK += "meta-qt5/recipes-qt/qt5/qt5-creator_git.bb"
-
-EOF
-
-
-yocto-check-layer -d \
- --dependency \
- $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-openembedded/meta-python \
- $AGLROOT/external/meta-openembedded/meta-networking \
- $AGLROOT/external/meta-security \
- $AGLROOT/external/meta-openembedded/meta-perl \
- $AGLROOT/meta-agl/meta-agl-core \
- $AGLROOT/external/meta-qt5 \
- --additional-layers \
- $AGLROOT/external/meta-qt5 \
- $AGLROOT/external/meta-python2 \
- -- \
- $AGLROOT/meta-agl-demo
-
-cat ${TMPROOT}/testbuild-ycl/conf/bblayers.conf
-
-[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl
-
-exit 0